AVC/h.264 videos are not rendered with proper lightness values

RESOLVED DUPLICATE of bug 879099

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 879099
4 years ago
4 years ago

People

(Reporter: avada, Unassigned)

Tracking

Trunk
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 815515 [details]
Screenshot of AVC video with rendering error.

When mp4/AVC videos are played with Firefox's player the videos looks too light and pale.
By the looks of it they're rendered like they were full range videos, even though they're limited range videos.
Testing is easy:
Youtube has vp8/webm and avc/mp4 encodes of the same video. To test these can be downloaded with one of the numerous tools and then played back with firefox.
(Reporter)

Comment 1

4 years ago
Created attachment 815516 [details]
VP8 video, rendered normally.
(Reporter)

Updated

4 years ago
Version: 24 Branch → Trunk
(Reporter)

Comment 2

4 years ago
Anyone here?

Anyway... Update on the issue. If I disable "media.windows-media-foundation.use-dxva" I get proper video but naturally the CPU usage jumps up.
So it seems its something related to DXVA hardware acceleration.
This is a driver issue, I've asked nvidia for help but got nowhere.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 879099
(Reporter)

Comment 4

4 years ago
At least I know the reason. :)
You need to log in before you can comment on or make changes to this bug.