"No vibration" preference should apply globally

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
10 months ago

People

(Reporter: sean.m456, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/536.30.1 (KHTML, like Gecko) Version/6.0.5 Safari/536.30.1

Steps to reproduce:

Turned off all vibration through Settings -> Sound -> Vibration


Actual results:

Home button vibration was still active.


Expected results:

Home button vibration should have ceased.
I can confirm this.
Status: UNCONFIRMED → NEW
Component: Hardware → General
Ever confirmed: true
OS: All → Gonk (Firefox OS)
Hardware: All → Other
Oh, sorry, this is the System app.

Basically we would need to change this line so that it only runs if the vibrate preference is set to true.
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/hardware_buttons.js#L161
Component: General → Gaia::System
Assignee: nobody → joshua-smith
Summary: ZTE Open Home Button Vibration does not turn off → Home Button Vibration does not turn off
Where does the vibration preference code live in the Settings app?
Flags: needinfo?
That was answered by :vingtetun.  An idea that I had was to turn off vibration globally (e.g. disable navigator.vibrate) in gecko when this preference is set to "false."  Does this sound good?
Flags: needinfo?
If no one responds soon, I will assume that it is, and implement it accordingly.

Comment 6

5 years ago
I'm unfamiliar with the code base, but would this also disable the vibration that occurs when ringing? Because it is quite useful to have ringtone settings "Completely silent", "Only vibration", "Noise + (VibrationEnabled ? Vibration : Nothing)". Do you know what I mean?
Need-infoing the UX people!
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 8

5 years ago
I don't really understand -- do you want me to do something? Or are you saying you asked the "UX people" (who is that?) something? Please clarify.
(In reply to Johannes Bauer from comment #8)
> I don't really understand -- do you want me to do something? Or are you
> saying you asked the "UX people" (who is that?) something? Please clarify.

Oh, sorry.  UX stands for the User Experience team.  They are the ones who specify the interaction flows.  You do not have to do anything.  I need-infoed them to get their feedback.
Blocks: 941252

Comment 10

5 years ago
Hi Joshua, please let us know exactly what you're looking for feedback on. Is it the patch in comment #2? Also, please note that the UX team is responding to koi+ and koi? bugs first, to get 1.2 out, followed by 1.3? and 1.3+, which is in line with QA and release priority. We are responding to bugs like that after those, so a delay in response is normal at this time.
Hello Stephany!

I was actually referring to https://bugzilla.mozilla.org/show_bug.cgi?id=925497#c4.  I completely understand about the delay.

Comment 12

5 years ago
Got it. To that end, I've flagged Neo, who is UX for Settings on System Platform. Neo, the idea (Gaia side) is about disabling vibration (see above). It has Gecko impact, though, so I've also flagged Tim to assess that impact.
Flags: needinfo?(timdream)
Flags: needinfo?(nhsieh)
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

5 years ago
Blocks: 885716

Comment 13

5 years ago
Hi Everyone, 
I think if user turn off the vibrate in settings,
in theory, that means users don't want any vibrate when they received calls.

But in this kind of layout design, users will aussume that option will control whole items. 
So I will prefer to turn off whole vibrate function.  Not just for phone call. 

What do you think ?
Flags: needinfo?(nhsieh)
Neo:

That is exactly what I was thinking in comment 4.  Good to hear that you agree :)
Summary: Home Button Vibration does not turn off → "No vibration" preference should apply globally
I have no opinion on this. Although I would imagine the vibration give people a definite feedback on capacitive hardware buttons (which is the case for our current low-end phones).
Flags: needinfo?(timdream)
Would someone else like to take this?
Assignee: joshua-smith → nobody

Comment 17

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.