Closed Bug 925550 Opened 6 years ago Closed 6 years ago

[B2G][Email] Scrolling marquee for long email addresses in the action menu header glitches when address reaches 34 characters before the @ symbol

Categories

(Core :: Graphics, defect)

26 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 929362
blocking-b2g -
Tracking Status
b2g18 --- unaffected
b2g-v1.2 --- affected

People

(Reporter: mvaughan, Unassigned)

References

Details

(Keywords: regression, Whiteboard: burirun2)

Attachments

(2 files)

Description:
The automatically scrolling marquee for long email addresses in the action menu header appears to glitch when the email address reaches 34+ characters before the "@" symbol. In order to make the marquee visibly scroll, the user has to tap the screen repeatedly.

Repro Steps:
1) Update Buri to Build ID: 20131010004001
2) Launch the Email app
3) Tap on the Create New Email icon (pencil in a box)
4) Tap on the "To:" text field
5) Type a fake email address containing 34+ characters before the "@" symbol
6) Tap on the contact bubble

Actual:
User must tap the screen repeatedly in order to have the email address scroll in the header; marquee scrolling glitches.

Expected:
Email address automatically scrolls back and forth.

Environmental Variables
Device: Buri
Build ID: 20131010004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/3f16dc100b1f
Gaia: 51f3c79ea93bb91d3b12e50b49d203a049a94a9b
Platform Version: 26.0a2

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/8588/
See attached: logcat.txt & LongEmailHeaderGlitch.mp4
Optional workarounds: Email contains 33 characters or less before the "@" symbol.
This bug does not repro on the 10/09/13 1.1 build.

Environmental Variables
Build ID: 20131009041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 53e2a70d85fb3748d0768218a5efffe5806073f0
Platform Version: 18.1
Summary: [B2G][Email] Scrolling marquee for long email addresses in the action menu header glitches when address reaches 34 characters → [B2G][Email] Scrolling marquee for long email addresses in the action menu header glitches when address reaches 34 characters before the @ symbol
Two questions here:

1. QA - Can you check to see if this UX is horizontal scrollable?

2. UX - Was there any intentional UX change here to move away from marquee? If not, what's UX take on the severity of this bug?
Flags: needinfo?(firefoxos-ux-bugzilla)
We're still using the exact same marquee logic as we have been since this feature was implemented.  It's a non-interactive (no scrolling by the user) CSS keyframe animation on translateX that takes 15 seconds.  See marquee.js and marquee.css in the e-mail app.

I suggest looking for other bugs in the same time-frame related to platform graphics regressions and duping this to that.  From the video and description it appears that the animation keeps running in the background, but only repaints when the user taps the screen.  There might be something interesting in the logcat for graphics engineers.
Flags: needinfo?(firefoxos-ux-bugzilla)
Okay. On that basis, bouncing over to gfx.
Component: Gaia::E-Mail → Graphics
Product: Boot2Gecko → Core
Version: unspecified → 26 Branch
Blocks: GFXB2G1.2
blocking-b2g: --- → koi?
QA Contact: laliaga
Actually works for me on Unagi, but I do have some local changes.  Do we have a reproduced case on other devices?
(In reply to Milan Sreckovic [:milan] from comment #6)
> Actually works for me on Unagi, but I do have some local changes.  Do we
> have a reproduced case on other devices?

It reproduces on Buri. If I recall, there's some differences in what preferences are enabled on Buri vs. Unagi, right? It probably has something to do with that.
If you want, we could check this on a leo device as well. Let me know if you want that.
The marquee not scrolling issue first occurs on the first 1.2 build (6/21).

- First occurs on Buri Central 1.2 -
Gaia   e2f19420fa6a26c4287588701efaec09a750dba1
SourceStamp 7ba8c86f1a56
BuildID 20130621031231
Version 24.0a1

- Occurs on Buri Central 1.3 as well -
Build ID: 20131010004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/3f16dc100b1f
Gaia: 51f3c79ea93bb91d3b12e50b49d203a049a94a9b
Platform Version: 26.0a2

- Does not occur Buri 1.1 -
Gaia   53e2a70d85fb3748d0768218a5efffe5806073f0
SourceStamp c630289d6388
BuildID 20131009041203
Version 18.0
Can we check to see if this reproduces on a leo 1.2 device as well?
Keywords: qawanted
Also occurs on latest Leo aurora 1.2. Email does not autoscroll.

Environment:
Gaia   d562c8f6eaed158bf5afa556f10c2f2e8ae8137f
SourceStamp 690f28662ace
BuildID 20131014004003
Version 26.0a2
Keywords: qawanted
Markus, looking for somebody that can triage this in CSS animation/graphics - can you take a look?
Flags: needinfo?(mstange)
I've verified that the patch in bug 929362 fixes this. Yay!
Depends on: 929362
Flags: needinfo?(mstange)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929362
blocking-b2g: koi? → -
No longer depends on: 929362
You need to log in before you can comment on or make changes to this bug.