Search suggestions require an extra tap to hit

VERIFIED FIXED in Firefox 26

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: ibarlow, Assigned: lucasr)

Tracking

({regression, reproducible})

26 Branch
Firefox 28
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox26 fixed, firefox27 verified, firefox28 verified, b2g-v1.2 fixed, fennec26+)

Details

Attachments

(1 attachment)

At some point during our start page redesign, it looks like we changed the behaviour of our search suggestions such that now it requires two taps to trigger instead of just one. We should fix that. 

Expected: I type a few letters, and can tap on a search suggest tile and instantly trigger a search

Actual: I need to tap twice now: once to dismiss the keyboard, and once to trigger the search.
Didn't even notice! Yeah, reproducible.
tracking-fennec: --- → ?
OS: Mac OS X → Android
Hardware: x86 → ARM
I can't repro on my Galaxy Nexus, 4.2.2, FF 27 (Nightly).
This seems fixed for me as well (10/15). Ian, are you still able to reproduce?
Still repros for me using a 10/15 nightly. First tap hides the keyboard. Second does the suggestion.
Yep, still able to reproduce this as well. 

Nexus 4, Android 4.3, Nightly 10/16
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 26+
Status: NEW → ASSIGNED
Comment on attachment 823428 [details] [diff] [review]
Handle touch events in HomeSearchListView with onTouchEvent (r=sriram)

Apparently, touch event interception + requestFocus() don't go so well on ListViews.
Attachment #823428 - Flags: review?(sriram)
Attachment #823428 - Flags: review?(sriram) → review+
Comment on attachment 823428 [details] [diff] [review]
Handle touch events in HomeSearchListView with onTouchEvent (r=sriram)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new about:home (bug 862793)
User impact if declined: extra tap needed to trigger a search suggestions while the virtual keyboard is on screen.
Testing completed (on m-c, etc.): local testing for now, let's bake this in Nightly for a few days and then uplift it.
Risk to taking this patch (and alternatives if risky): low, just changes the way to capture touch events to dismiss the virtual keyboard while showing awesomescreen search results. 
String or IDL/UUID changes made by this patch: n/a
Attachment #823428 - Flags: approval-mozilla-beta?
Attachment #823428 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/200fa2ac65e4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Status: RESOLVED → VERIFIED
Attachment #823428 - Flags: approval-mozilla-beta?
Attachment #823428 - Flags: approval-mozilla-beta+
Attachment #823428 - Flags: approval-mozilla-aurora?
Attachment #823428 - Flags: approval-mozilla-aurora+
Verified fixed on:
Build: Firefox for Android 27.0a2 (2013-12-06)
Device: Samsung Galaxy Nexus
OS: Android 4.2.1
You need to log in before you can comment on or make changes to this bug.