Remove Cmd-Left Arrow mapping on OSX

RESOLVED DUPLICATE of bug 289384

Status

()

Firefox
Keyboard Navigation
RESOLVED DUPLICATE of bug 289384
5 years ago
4 years ago

People

(Reporter: Rolf, Unassigned)

Tracking

24 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Press Cmd-Left in a form field (much like this one)

See also https://support.mozilla.org/en-US/questions/973611#answer-488671


Actual results:

Firefox loaded the previous page, loosing all edits in the form


Expected results:

The cursor should have moved to the beginning of the line.

(same problem with Cmd-Right)
Component: Untriaged → Keyboard Navigation
Hardware: x86 → All

Comment 1

4 years ago
I confirm this bug. Similar problem not present in Safari, Chrome. Firefox is officially off the list as a tool for writing.

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Blocks: 950073
Whiteboard: [triage] [defect] p=0
I can't reproduce this behavior with Firefox 24 or Nightly 29. I use CMD+Left and CMD+Right in web forms all the time. Do you have any add-ons installed? Can you reproduce this problem in Safe Mode?
This bug may be related to or a duplicate of bug 289384.
See Also: → bug 289384

Comment 4

4 years ago
It's for example on all websites using the CKEditor (a lot of websites use the CKEditor). It's not a problem with regular textareas.

1. go to http://ckeditor.com/
2. click the demo link
3. edit the text in the editor
4. press cmd-left to go to the beginning of the line
5. the cursor should be on the beginning of the line, but Firefox loads the previous page

Comment 5

4 years ago
Okay, Bug 289384 fixed this in CKEditor, too. Thanks for the fix, it was very annoying. :)

Comment 6

4 years ago
This is a dupe indeed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 289384

Updated

4 years ago
No longer blocks: 950073
Whiteboard: [triage] [defect] p=0
You need to log in before you can comment on or make changes to this bug.