Note: There are a few cases of duplicates in user autocompletion which are being worked on.

[FIX] topmargin="0" leftmargin="0" not applied

VERIFIED FIXED in mozilla0.9.4

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: bene, Assigned: Marc Attinasi)

Tracking

({topembed})

Trunk
mozilla0.9.4
x86
All
topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
<body topmargin="0" leftmargin="0">

I am not quite sure if the margin's are suppost to be part of the HTML specs, but if they are,
they aren't quite working properly.  If they are not part of the HTML spec, then I appologize.

But it wouldn't hurt to include support for these tags.

Ben Efros

Updated

18 years ago
Assignee: rickg → kipp

Comment 1

18 years ago
Kipp-- I don't think we do topmargin and leftmargin this way, do we? If not,
please close this bug.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 2

18 years ago
1. Navigator never supported "topmargin" or "leftmargin" for body elements; it
does support "marginwidth" and "marginheight" which provides symmetric
left/right top/bottom margins, but is deprecated in favor of the css approach.

2. HTML4 has no such attributes for the BODY element either.

Therefore, we aren't going to implement them in gecko.

If you want to affect the top/left margins for an element, use css:

<body style="margin-top: 0; margin-left: 0">

for example.
(Reporter)

Updated

18 years ago
Status: RESOLVED → CLOSED
This would be an easy 'bug' to fix. (Netscape people: See WRMB 7958.)
Status: CLOSED → REOPENED
Keywords: topembed
Resolution: INVALID → ---
(buster is no longer working on mozilla)
Assignee: buster → attinasi
Status: REOPENED → NEW

Comment 5

16 years ago
jst, hyatt: any idea who could fix this, and/or how?
It's a simple matter of adding code to the BODY tag's MapAttributesInto stuff.
We already do it for some attributes, extending it to work with the other
attributes should be trivial.

Comment 7

16 years ago
could we _please_ include support for this, even though it's not part of html 4.

If mozilla was completely based on standards, it would turnout something like
amaya! :(

But I mean, mozilla should _support_ both standards and non-standards.

Cause otherwise without support for this, sites won't turn out quite as they
should... www.shop-uk.co.uk -- this site isn't such a good example since it
looks nearly fine even without support,

but please, include <body topmargin=*> !

Comment 8

16 years ago
sorry, wrong url above...

www.shop-tv.co.uk
.
Status: NEW → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → DUPLICATE

*** This bug has been marked as a duplicate of 26788 ***
(Assignee)

Comment 10

16 years ago
Reopening bug. I'm going to fix for this, so marking it a dup of a WONTFIX bug
is not right.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 11

16 years ago
re-accepting
Status: REOPENED → ASSIGNED
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 12

16 years ago
Created attachment 45840 [details] [diff] [review]
PATCH to map topmargin and leftmargin attributes in QuirksMode
(Assignee)

Comment 13

16 years ago
Patch has been attached to map the topmargin and leftmargin to the body in
quirks mode, for compatibility with IE. Seeking reviews (r and sr).
(Assignee)

Comment 14

16 years ago
Created attachment 45845 [details]
Testcase
sr=jst

Comment 16

16 years ago
r= alexsavulov
(Assignee)

Updated

16 years ago
Summary: topmargin="0" leftmargin="0" not applied → [FIX] topmargin="0" leftmargin="0" not applied
(Assignee)

Comment 17

16 years ago
Checked into branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
I have to say I don't like the idea of making this quirks mode only.  I think
it's good to keep the list of quirks to a minimum -- and there's no reason
supporting all these extra features breaks standards (any more than all the ones
we already do).
(Assignee)

Comment 19

16 years ago
dbaron, does the HTML spec say what should be done with attributes that are NOT
part of the standard? I would think that, if we had a true strict-DTD parser,
these attributes would be thrown out anyway. I'm confused, but you know more
than I about this: is it really 'standards compliant' to honor non-standard
attributes (or tags for that matter)?

I'd be more than happy to remove the quirk-check, I was under the impression
(possibly erroneous) that non-standard attributes, and especially IE-specific
ones :), were not allowed in standard mode.
(Assignee)

Comment 20

16 years ago
... or is this the key to understanding your statement?

> ... (any more than all the ones we already do).
Partly, although if we have features that don't exist in standard mode, that
will discourage people from using it.

IMO, quirks mode should be used only when we need to deviate from a standard to
make the web work -- otherwise we should act as though we didn't have multiple
modes.  This will keep the number of differences to a minimum and make our lives
much less confusing.
(Assignee)

Comment 22

16 years ago
I opened bug 95530 for further discussion of UnQuirking this. Let's discuss it
there.

Comment 23

16 years ago
Marking verified in the Sept 05th build (2001-09-05-05)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.