Intermittent test_periodicWave.html | Test timed out.

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86_64
Mac OS X
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=29038566&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitest-1 on 2013-10-12 07:29:09 PDT for push 40fbd6880056
slave: talos-r4-snow-073

07:53:31     INFO -  162556 INFO TEST-START | /tests/content/media/webaudio/test/test_periodicWave.html
(screenshot)
07:58:34     INFO -  162557 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_periodicWave.html | Test timed out.
Like bug 924841, it's as if the function passed to addLoadEvent is never run.
Depends on: 924841

Comment 2

5 years ago
(In reply to comment #1)
> Like bug 924841, it's as if the function passed to addLoadEvent is never run.

This is very weird...
Blocks: 937075
Blocks: 937072
20:34:56     INFO -  973 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Should be correctly up-mixed to three channels
20:39:58     INFO -  974 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Buffers must have the same length
20:39:58     INFO -  975 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Found 0 different samples, maxDifference: 0, first bad index: -1 with source offset 0 and destination offset 0
20:39:58     INFO -  976 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Buffers must have the same length
20:39:58     INFO -  977 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Found 0 different samples, maxDifference: 0, first bad index: -1 with source offset 0 and destination offset 0
20:39:58     INFO -  978 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Buffers must have the same length
20:39:58     INFO -  979 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Found 0 different samples, maxDifference: 0, first bad index: -1 with source offset 0 and destination offset 0
20:39:58     INFO -  980 INFO TEST-END | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | finished in 414ms

How could test_scriptProcessorNodeChannelCount.html finish in 414ms?
test_scriptProcessorNodeChannelCount.html produces two 2048-sample buffers in realtime.  At 44.1 kHz that is 43 ms.
(In reply to Karl Tomlinson (:karlt) from comment #4)
> test_scriptProcessorNodeChannelCount.html produces two 2048-sample buffers
> in realtime.  At 44.1 kHz that is 43 ms.

20:34:56     INFO -  973 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Should be correctly up-mixed to three channels
20:39:58     INFO -  974 INFO TEST-PASS | /tests/content/media/webaudio/test/test_scriptProcessorNodeChannelCount.html | Buffers must have the same length

The 2 messages span 5 minutes, which is weird.
Which log are you looking at?  I get "Unknown run ID." for the link here.
Android logs seem to buffer up output and then many lines get the same timestamp, and so timestamps are not so helpful.
Blocks: 943223
Blocks: 945171
Blocks: 947824
Priority: -- → P2
Comment hidden (Treeherder Robot)
Blocks: 966408
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.