Edit/Share picture results in blank form

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: pancake, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 816256 [details]
2013-10-12-20-09-08.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131010030202

Steps to reproduce:

Open gallery, select an image, tap on share/edit button


Actual results:

blank form as shown in the image.


Expected results:

I'm reproducing this issue on Geeksphone PEAK on latest GIT.. and looks like the problem is related to opengl. which afaik is because the driver that comes with the OS is armv6 and the system is compiled with armv7. So i guess the system have no way to detect such errors or disable opengl when it is broken or non available.

I/Gecko   ( 5554): OpenGL version detected: 200
I/Gecko   ( 5554): SharedSurface_Gralloc::Create -------
I/Gecko   ( 5554): SharedSurface_Gralloc::Create -------
E/GeckoConsole( 5554): [JavaScript Warning: "Error: WebGL: Can't get a usable WebGL context" {file: "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1151}]
E/GeckoConsole( 5554): [JavaScript Error: "TypeError: gl is null" {file: "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1154}]
(In reply to pancake from comment #0)
> I/Gecko   ( 5554): OpenGL version detected: 200
> I/Gecko   ( 5554): SharedSurface_Gralloc::Create -------
> I/Gecko   ( 5554): SharedSurface_Gralloc::Create -------
> E/GeckoConsole( 5554): [JavaScript Warning: "Error: WebGL: Can't get a
> usable WebGL context" {file:
> "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1151}]
> E/GeckoConsole( 5554): [JavaScript Error: "TypeError: gl is null" {file:
> "app://gallery.gaiamobile.org/js/ImageEditor.js" line: 1154}]

Is this the only error you are getting on the logcat? What is the size of the image? Since we're using a 3D canvas for rendering we already hit issues where we'd run out of graphics memory when editing large images; this might be related.
(Reporter)

Comment 2

5 years ago
The size of the image doesn't seems to matter at all. I've been trying with images from the web and screenshots made in the same device. WebGL is broken on Gp-Peak for so long. And yep. that's all the errors I get.
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.