Closed Bug 926166 Opened 6 years ago Closed 4 years ago

changing the dictionary (language) is sometimes ignored

Categories

(Core :: Spelling checker, defect)

24 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44

People

(Reporter: vincent-moz, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 Iceweasel/24.0 (Beta/Release)
Build ID: 20130918225509

Steps to reproduce:

1. Go to https://twitter.com/
2. Paste a tweet with the middle button.
3. Over this area, click with the right button to make the menu appear.
4. Choose Languages → French (XX) (moderne) with the left button.


Actual results:

Nothing changed (the menu just disappeared). This problem occurs from time to time.


Expected results:

The dictionary (language) should have been selected for spell checking and spell checking results should have changed from English (default) to French.
Component: Untriaged → Spelling checker
Product: Firefox → Core
I can confirm that I see the same sort of behavior, most frequently on Facebook and Google+ text boxes.

I'm running Debian Unstable, with the packaged 'iceweasel', user agent
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 Iceweasel/26.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is this still an issue? Can you provide a reproducible test case? See bug 1073827, comment #33.
Flags: needinfo?(vincent-moz)
I don't remember that this bug occurred recently. I've just done a few tests, and I couldn't reproduce.
Flags: needinfo?(vincent-moz)
Closing this bug since the reporter can't reproduce it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Reopening since this has just occurred with:
Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.3.0

I paste some text with the middle button on https://twitter.com/ then selected "Languages" → "English (United States)" in the context menu, but it remained at "French".
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
All the fixes for the dictionary problems were landed on Firefox 44, currently in "Nightly".
I am sorry to say that what happens in Iceweasel 38.3 is pretty irrelevant.
I tried what you said on Windows in Twitter and it worked for me.

You test case DOES NOT comply with the requirements for a reproducible test case set out in bug 1073827 comment #33.

Please leave the bug closed until you can present a *reproducible* test case which is *fully documented* using a *relevant* version.

BTW, open or not, this bug has received no attention in two years and it won't receive any attention without a reproducible case.

It is most likely fixed by the rework of this area in bug 717433, bug 1200533, bug 697981, bug 1193293, bug 1204147, bug 1204540, bug 1205983, more specifically bug 1204147 or bug 1193293.

Besides, I checked, the Twitter page has a <div contenteditable> inside it to type the text into, so on those elements random things used to happen.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
You need to log in before you can comment on or make changes to this bug.