Closed Bug 926253 Opened 6 years ago Closed 5 years ago

When will we have Bluetooth webAPI documentation?

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1005848

People

(Reporter: mauricio, Unassigned)

References

Details

We need to know how to use Bluetooth WebAPI.
There is a Wiki page [0] that says Bluetooth is only available to certified apps, but I can not find info about "how to use Bluetooth in my webapp".

This info would include "how to fake-certify my webapp and test it in my FirefoxOS device/Simulator"

Thank you!
[0] https://wiki.mozilla.org/WebAPI#Planned_for_initial_release_of_B2G_.28aka_Basecamp.29
Hi Mauricio,

We haven't had DOM API for Gaia developers to develop apps which transferring data via Bluetooth. We do have Bluetooth DOM APIs right now, but they can only be used by certified and privileged apps.

I'm going to propose a draft of new Bluetooth DOM API soon on https://wiki.mozilla.org/WebAPI/WebBluetooth (it's out-of-date now). Hope that we can have interface like BluetootSocket for Gaid developers to use Bluetooth intuitively. I think we'll use bug 674737 for discussion. So please cc yourself if you want to get involved.

Thanks!
After several months, we are about to have a set of exposed WebBluetooth API. :)

Firefox OS Bluetooth team has been working on defining/implementing a set of new WebBluetooth API from May. Please visit [1] to get more information.

We split the whole set of BT API into 3 parts:

  (A) Basic Bluetooth API - including basic Bluetooth properties setter/getter, discovery and pair.
  (B) Bluetooth Low Energy(BLE) API - will provide the capability to let apps communicate via BLE.
  (C) Classic Bluetooth Socket - socket-like interface which will work on top of classic RFCOMM/L2CAP profiles.

According to our plan, these 3 items will be implemented in order. (A) and (B) are target to be done by the end of November.

Moreover, a W3C group "Web Bluetooth Community Group" has been already proposed (and created) by Jeffrey Yasskin from Google. Not only Mozilla and Google but also many people from other communities/organizations have joined the group to complete the WebBluetooth API. :)

I'm going to close this as resolved duplicate of bug 1005848, which is the meta bug of WebBluetooth API refinement of Firefox OS. Please feel free to ask further questions there.

Thanks!

[1] https://wiki.mozilla.org/WebAPI/WebBluetooth
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: webbt-api-meta
OS: Android → Gonk (Firefox OS)
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.