Inspector breadcrumbs context menu jumps around

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
2 months ago

People

(Reporter: fitzgen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 816687 [details]
screenshot

Apparently in some kind of circumstance, on some version of windows, the context menu for a stack frame won't sit still.

https://twitter.com/stochnagara/status/389691774525911041
I'm going to remove this menu completely in bug 905981.
Depends on: 905981

Comment 2

5 years ago
Actually, the bug is not for the debugger but for the Inspector.
You can see the screenshot carefully.
I have just tested and the problem is still there.
Component: Developer Tools: Debugger → Developer Tools: Inspector
OS: Mac OS X → All
Hardware: x86 → All
Summary: stack frame's context menu jumps around → Inspector breadcrumbs context menu jumps around

Comment 3

5 years ago
I'm seeing this in FF29 - it will even cross over to the wrong monitor at hard top-left of screen when devtools are open (not even maximized) on monitor 2 or 3.
Whiteboard: [devedition-40]
I can't reproduce this bug anymore. Feel free to re-open if that still occurs for you.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: [devedition-40]

Comment 5

3 years ago
Patrick, this bug still fails as per my Comment #3.  If you want more pictures, let me know. Actually, this problem is better documented here https://bugzilla.mozilla.org/show_bug.cgi?id=967096

Updated

3 years ago
Flags: needinfo?(pbrosset)
(In reply to Russ from comment #5)
> Patrick, this bug still fails as per my Comment #3.  If you want more
> pictures, let me know. Actually, this problem is better documented here
> https://bugzilla.mozilla.org/show_bug.cgi?id=967096
I'm guessing that bug 967096 is better to track the particular issue in comment 3. The current bug was about the fact that the popup would always move, even on one monitor.
Flags: needinfo?(pbrosset)

Comment 7

3 years ago
(In reply to Patrick Brosset [:pbrosset] [:patrick] from comment #6)
> The current bug was about the fact that the popup would always
> move, even on one monitor.

Always? :

>Apparently in some kind of circumstance, on some version of windows, the context menu for a stack frame won't sit still. 

But yes, any kind of popup, including humble tooltips, are pretty much always randomly positioned for me.  For example, the color picker ALWAYS tries to display on monitor 4 in my setup <- I only have 3!

By way of feedback, the setting RESOLVED WORKSFORME, unless agreed upon by those suffering the bug (inc the OP) is so annoying as to get people riled up.  Please tell me how I am meant to file it, "mentally" - is it not a bug now?  Will this bug now not appear for those searching for something to work on?
Flags: needinfo?(pbrosset)
(In reply to Russ from comment #7)
> But yes, any kind of popup, including humble tooltips, are pretty much
> always randomly positioned for me.  For example, the color picker ALWAYS
> tries to display on monitor 4 in my setup <- I only have 3!
Isn't this bug 967096 exactly? I don't think that's what comment 0 describes. That's why I closed this bug.
Reporting the same issue in several bugs isn't going to increase its chances of being fixed.

> Please tell me how I am meant to file it, "mentally" - is it not a bug
> now?  Will this bug now not appear for those searching for something to work
> on?
Not sure I understand the question here. Bug 967096 is fine for this issue, and it will show up for people searching for things to work on.
Flags: needinfo?(pbrosset)

Comment 9

3 years ago
(In reply to Patrick Brosset [:pbrosset] [:patrick] from comment #8)
> (In reply to Russ from comment #7)
> > But yes, any kind of popup, including humble tooltips, are pretty much
> > always randomly positioned for me.  For example, the color picker ALWAYS
> > tries to display on monitor 4 in my setup <- I only have 3!
> Isn't this bug 967096 exactly? I don't think that's what comment 0
> describes. That's why I closed this bug.
> Reporting the same issue in several bugs isn't going to increase its chances
> of being fixed.
> 
> > Please tell me how I am meant to file it, "mentally" - is it not a bug
> > now?  Will this bug now not appear for those searching for something to work
> > on?
> Not sure I understand the question here. Bug 967096 is fine for this issue,
> and it will show up for people searching for things to work on.

Maybe this will help you understand my question. Unless I'm mistaken, You never reported seeing this issue. You marked it "WORKSFORME". To me, that's meaningless and nonsensical. Hence, "How am I meant to file this?"

Better?

Comment 10

3 years ago
Still broken, Nightly and Dev Ed.  If I could reopen the bug, I would.

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.