Closed Bug 926576 Opened 6 years ago Closed 6 years ago

Add a quiet mode to mochitest runner

Categories

(Testing :: Mochitest, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 937181

People

(Reporter: fitzgen, Unassigned)

Details

When you run multiple xpcshell tests, it only prints out a line saying what test it is running. Unless a test fails, then it prints out the full log for that test.

However mochitests always print all their logs.

This can be a real hassle, because I notice that when I run mochitests, they often beach ball for periods of time while they wait for the logging IO to complete (I use emacs shell, and it isn't fast, but I can't live without it). When I pipe stderr and stdout to /dev/null, the time to run tests halves. This isn't a long term solution because if a test does fail, I do want to have the full logs for that specific test.

On top of that, when all logs are always dumped, it is more info to mentally sort through when you are trying to diagnose failures. First I have to sort through all the different tests, than I can start looking at the logs of the failed test.

I think that mochitests should have a mode where they assume the behavior of xpcshell tests, and only print out full "INFO", "TEST-PASS", and "TEST-FAIL", etc logs when the test actually fails.
What terminal are you using? Some terminals are known to "buffer up" and slow down processes doing blocking I/O when writing to the terminal.
(In reply to Gregory Szorc [:gps] from comment #1)
> What terminal are you using? Some terminals are known to "buffer up" and
> slow down processes doing blocking I/O when writing to the terminal.

Emacs
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 937181
You need to log in before you can comment on or make changes to this bug.