Closed Bug 926654 Opened 6 years ago Closed 6 years ago

linkedin site fails to load - grey screen

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kbrosnan, Unassigned)

References

()

Details

(Whiteboard: [country-all] [js])

Linkedin site fails to render anything useful after logging in. Firefox for Android 24 and 27. I also tried Phony's iPhone and Android stock browser UAs without success.
Blocks: linkedin.com
It seems to work on Chrome for Android, though. I've used the "Send Feedback" link on the bottom of LinkedIn pages to make note of this.
Linkedin also fails on Firefox OS the same way. After login I see only a grey screen.
Kevin,

thanks for the bug report. 

* Could you tell us if you are redirected to the mobile site from http://linkedin.com/ ?
* Do you have UA override on on Firefox OS or did you remove it?
* Did you dive a bit more into the bug?

We are negotiating with LinkedIn already, see  Bug 826348.
Flags: needinfo?(kbrosnan)
* yes, touch.www.linkedin.com as posted in the URL
* This is on Firefox for Android
* I tried to use an iPhone and Chrome Android UA
Flags: needinfo?(kbrosnan)
Digging in for analysis.
Assignee: nobody → miket
Not really explaining why the site fails to load, but a few things that pop up:

[13:29:18.741] "[Q] Unhandled rejection reasons (should be empty):" [object Array]

It's possible that the site doesn't render if a promise is rejected... , but there's some other things going on too.

from https://gist.github.com/anonymous/e73e7b598b5f5cb1ba69#file-gistfile1-txt-L44-L47:

if (n) {
  b.browser = "firefox";
  b.supported = false
}

http://touch.licdn.com/aabaf1/javascripts/LinkedIn.libs.js, 
"define("app/LinkedIn/libs",["zepto","underscore","Q","Backbone","jscache","Crypto","iScroll"]". They've got an older version of zepto that isn't FF friendly and iScroll appears to only be interested in webkit here (not sure if that's true for all versions).

I'd be happy to do a more in depth analysis to assist LinkedIn once we have the right contacts in place.
Assignee: miket → nobody
Whiteboard: [country-all] [js]
They've fixed this now--seems to work quite nicely on Firefox for Android.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.