Closed Bug 926830 Opened 6 years ago Closed 5 years ago

Some tests still need cleanup for their plugin enabledState usage

Categories

(Core :: Plug-ins, defect, P3)

defect
Points:
5

Tracking

()

RESOLVED FIXED
mozilla37
Iteration:
37.3 - 12 Jan

People

(Reporter: gfritzsche, Assigned: jmaher)

References

Details

Attachments

(5 files, 4 obsolete files)

johns made me notice that in bug 899080 i missed using a common setTestPluginEnabledState() function in at content/, searching through dxr more exhaustively i think those are the last tests that need clean-up for this:

content/base/test/test_mixed_content_blocker.html
content/base/test/test_object.html
content/base/test/chrome/test_bug391728.html
dom/plugins/test/mochitest/test_idle_hang.xul
toolkit/mozapps/extensions/test/browser/browser_CTP_plugins.js
widget/tests/test_plugin_input_event.html
widget/tests/test_plugin_scroll_consistency.html
widget/tests/test_plugin_scroll_invalidation.html
Attached patch Cleanup, content/ (obsolete) — Splinter Review
Attachment #8377128 - Flags: review?(bugs)
Attachment #8377129 - Flags: review?(benjamin)
Attachment #8377131 - Flags: review?(benjamin)
Attached patch Cleanup, widget/tests/ (obsolete) — Splinter Review
Attachment #8377135 - Flags: review?(roc)
Comment on attachment 8377128 [details] [diff] [review]
Cleanup, content/

Not super nice to have same functions defined many times, but I blame the one 
who started to add head.js for the first place.

s/it's/its/
Attachment #8377128 - Flags: review?(bugs) → review+
Try uncovered inter-bug-issues again, new push:
https://tbpl.mozilla.org/?tree=Try&rev=7351d1052647
Attachment #8377131 - Attachment is obsolete: true
Attachment #8377131 - Flags: review?(benjamin)
Attached patch Cleanup, content/, v2 (obsolete) — Splinter Review
Attachment #8377128 - Attachment is obsolete: true
More interbug dependencies, new try push:
https://tbpl.mozilla.org/?tree=Try&rev=954c3724d7aa
Attachment #8377543 - Attachment is obsolete: true
Attachment #8377539 - Attachment description: Clean, toolkit/, v2 → Cleanup, toolkit/, v2
Comment on attachment 8377539 [details] [diff] [review]
Cleanup, toolkit/, v2

The try run is looking good now. bsmedberg, can you review this part?
Attachment #8377539 - Flags: review?(benjamin)
Comment on attachment 8377544 [details] [diff] [review]
Cleanup, layout/

This fixes another intertest-dependency, the patch queue looks fine now on try.
Attachment #8377544 - Flags: review?(roc)
Comment on attachment 8377719 [details] [diff] [review]
Cleanup, content/, v3

The patch queue looks good on try now with additional test changes in content/, sorry about the double request.
Attachment #8377719 - Flags: review?(bugs)
Attachment #8377719 - Flags: review?(bugs) → review+
Attachment #8377129 - Flags: review?(benjamin) → review+
Attachment #8377539 - Flags: review?(benjamin) → review+
had to backout this changes since tbpl reported leaks in testruns like https://tbpl.mozilla.org/php/getParsedLog.php?id=35040337&tree=Mozilla-Inbound
Duplicate of this bug: 1030541
I'd rather over-estimate this for possibly mysterious leak investigations.
Points: --- → 5
Flags: firefox-backlog+
Assignee: georg.fritzsche → nobody
I took the original cleanup for widget/tests/ and added support for 2 additional tests (both mochitest-chrome tests: test_imestate.html and test_chrome_context_menus_win.html).  These pass locally as well as on try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=acaae2f68e4c

I did retriggers on the oth and m-5 runs and no leaks are showing up.
Attachment #8377135 - Attachment is obsolete: true
Attachment #8546602 - Flags: review?(gfritzsche)
Duplicate of this bug: 1115092
Comment on attachment 8546602 [details] [diff] [review]
cleanup widget/tests/* (2.0)

Great to hear, thanks for picking this up :)
Attachment #8546602 - Flags: review?(gfritzsche) → review+
https://hg.mozilla.org/mozilla-central/rev/562c336394da
Assignee: nobody → jmaher
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Iteration: --- → 37.3 - 12 Jan
You need to log in before you can comment on or make changes to this bug.