Closed Bug 926842 Opened 7 years ago Closed 7 years ago

unable to change status and tracking flag values once they are set

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
defect
Not set
blocker

Tracking

()

RESOLVED FIXED

People

(Reporter: standard8, Assigned: glob)

Details

(Keywords: regression)

Attachments

(1 file)

I've just noticed that I'm no longer able to change the status of some tracking flags for Thunderbird. There's no errors/warnings given, it just doesn't happen.

So far, flags I've found affected are:

tracking-thunderbird24
tracking-thunderbird25
status-thunderbird24

These were all set to a value to begin with.

tracking-thunderbird-esr24 did work, but only in the case it was unset to begin with.
This seems to also affect the blocking-b2g flags as well.
(In reply to Mark Banner (:standard8) from comment #0)
> I've just noticed that I'm no longer able to change the status of some
> tracking flags for Thunderbird. There's no errors/warnings given, it just
> doesn't happen.
> 
> So far, flags I've found affected are:
> 
> tracking-thunderbird24
> tracking-thunderbird25
> status-thunderbird24
> 
> These were all set to a value to begin with.
> 
> tracking-thunderbird-esr24 did work, but only in the case it was unset to
> begin with.

Can you provide a bug id or two that exhibit this behavior to aid us in debugging the issue?

dkl
Flags: needinfo?(mbanner)
confirming and taking; looks like you can set a value directly to koi+, but not change it from koi? to koi+.
Assignee: nobody → glob
Flags: needinfo?(mbanner)
(In reply to Mark Banner (:standard8) from comment #0)
> I've just noticed that I'm no longer able to change the status of some
> tracking flags for Thunderbird. There's no errors/warnings given, it just
> doesn't happen.
> 
> So far, flags I've found affected are:
> 
> tracking-thunderbird24
> tracking-thunderbird25
> status-thunderbird24

these flags are configured to display for certain products such as Thunderbird, MailNews Core, Mozilla Messaging, and support.mozillamessaging.com and I can see those when looking at a bug in one of those products. Can you provide a bug id from those where you are seeing this issue?

dkl
Attached patch 926842_1.patch β€” β€” Splinter Review
Attachment #817188 - Flags: review?(dkl)
Comment on attachment 817188 [details] [diff] [review]
926842_1.patch

Review of attachment 817188 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #817188 - Flags: review?(dkl) → review+
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/TrackingFlags/Extension.pm
Committed revision 9067.

i will try to get this pushed to prod asap.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Summary: status & tracking flags not working for Thunderbird → unable to change status and tracking flag values once they are set
this has been pushed to production.
Component: Extensions: TrackingFlags → Extensions
You need to log in before you can comment on or make changes to this bug.