Closed Bug 926877 Opened 11 years ago Closed 4 years ago

Windows uninstaller should offer to Reset Firefox

Categories

(Firefox :: Installer, enhancement, P5)

All
Windows
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1633505

People

(Reporter: gcp, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: uiwanted, Whiteboard: [ux needed])

Whenever you look at Firefox user forums where people are having serious problems, posts invariably begin with: "I uninstalled and reinstalled Firefox, but it did not solve the problem."

Due to the nature of most of those problems, the first steps any Windows user will try to solve the problem are almost guaranteed not to have any effect. The ones that would likely be more effective (reset firefox in about:support) are harder to find.

When the user uninstalls Firefox, we have a possibility to ask in the uninstaller if they're trying to resolve a problem, or no longer want to use the program. If the former, we can offer to  Reset Firefox, Reinstall Firefox (but keep settings), Reinstall Firefox (but delete all settings & user data) and a link to our suport sites. If the latter, we should uninstall but there's a nice possibility to insert an optional survey querying the reasons.
See Also: → 872241
Whiteboard: [ux needed]
>Reinstall Firefox (but keep settings), Reinstall Firefox (but delete all settings & user data)

These two should actually have said Uninstall, i.e. basically the same as what's already there.
OS: Windows 8 → All
Hardware: x86_64 → All
OS: All → Windows 7
Severity: normal → enhancement
Keywords: uiwanted
OS: Windows 7 → Windows
This isn't a bad idea, but the UX might be tricky; we don't want to look like we're doing some desperate cable provider-like user retention thing by getting in the way of people who really are just trying to uninstall.
Priority: -- → P5
The uninstall survey (on release since 63) highlighted that 41% of respondents who took the survey (this is opt-in) told us that the reason they are uninstalling Firefox is to reinstall it. These users uninstalling Firefox to re-install it do so in order to fix an issue (65%), update (10%) or reset to default (14%). Worth noting is that setting Firefox to a different language also often comes-up in user feedback.

Uninstalling/Reinstalling may not help users with profile-related issues and I agree it sounds valuable to expose a way to fix user issues at this particular moment:
- I want to update Firefox (Re-install Firefox and keep settings/user data?) - Users with app update disabled in old versions would have app update enabled on new versions given we recently removed the ability to disable app update.
- I want to reset my settings to default (reset Firefox?)
- I want to fix a problem (reset Firefox?)
- I want to change browser locale (install lang pack?)

Worth noting is that we now have a profile cleanup prompt on the stub installer:
- About 10% of stub installs happen where Firefox is already installed with the same version 
- About 15% of stub installs happen where Firefox is already installed with an older version

Michael, given the work you did on profile cleanup in the stub installer, do you feel this approach sounds relevant in the uninstaller (ultimately I'd expect this to reduce stub downloads/installs/profile cleanups)?
Flags: needinfo?(mverdi)

I didn't realize this was on file, I believe this has been addressed with bug 1633505. It's weird to dupe from the future but this seems like the reasonable way to handle it.

Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(mverdi)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.