Last Comment Bug 926997 - Eideticker noise caused by "WatcherService created" toast message
: Eideticker noise caused by "WatcherService created" toast message
Status: RESOLVED FIXED
:
Product: Testing
Classification: Components
Component: SUTAgent (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla27
Assigned To: Geoff Brown [:gbrown] (pto May 28-June 13)
:
Mentors:
Depends on: 927563
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 09:49 PDT by :Margaret Leibovic
Modified: 2013-10-17 05:05 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
eliminate toasts (6.41 KB, patch)
2013-10-15 16:03 PDT, Geoff Brown [:gbrown] (pto May 28-June 13)
wlachance: review+
Details | Diff | Review

Description :Margaret Leibovic 2013-10-15 09:49:11 PDT
I'm not familiar with the WatcherSerivce, but what's the reason for this toast message? It's throwing off eideticker results, so can we remove it an replace it with a log message instead?

http://eideticker.wrla.ch/framediff-view.html?title=Frame%20Difference%20Startup%20to%20about:home%20%28fresh%20profile%29%20%282013-10-14%29&video=videos/video-1381822474.13.webm&framediff=framediffs/framediff-1381822484.12.json&actionlog
Comment 1 Geoff Brown [:gbrown] (pto May 28-June 13) 2013-10-15 14:44:40 PDT
I don't find the watcher toasts useful. I would be happy to just have corresponding log messages.

On a side-note, I find it odd that the watcher is starting during a test...but I am not that familiar with the eideticker device setup. :wlach -- any thoughts here?
Comment 2 William Lachance (:wlach) 2013-10-15 14:52:06 PDT
(In reply to Geoff Brown [:gbrown] from comment #1)
> I don't find the watcher toasts useful. I would be happy to just have
> corresponding log messages.
> 
> On a side-note, I find it odd that the watcher is starting during a
> test...but I am not that familiar with the eideticker device setup. :wlach
> -- any thoughts here?

Probably got killed due to low memory, then it came back. I agree, it would be great to get rid of the toasts.
Comment 3 Geoff Brown [:gbrown] (pto May 28-June 13) 2013-10-15 16:03:48 PDT
Created attachment 817503 [details] [diff] [review]
eliminate toasts

Change doToast() to Log.i/w/e. Update version to 1.17. 

I noticed a second "WatcherService created" message and changed that to something more descriptive.
Comment 4 William Lachance (:wlach) 2013-10-16 08:52:16 PDT
Comment on attachment 817503 [details] [diff] [review]
eliminate toasts

Great, thanks!
Comment 5 Geoff Brown [:gbrown] (pto May 28-June 13) 2013-10-16 12:49:01 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/11c7c6810c73
Comment 6 Carsten Book [:Tomcat] 2013-10-17 05:05:55 PDT
https://hg.mozilla.org/mozilla-central/rev/11c7c6810c73

Note You need to log in before you can comment on or make changes to this bug.