mozContacts.getAll() time has regressed about 10%

RESOLVED FIXED

Status

()

Core
DOM: Contacts
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

(Blocks: 1 bug, {perf, regression})

Trunk
ARM
Gonk (Firefox OS)
perf, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c= p=4 s= u=])

(Assignee)

Description

5 years ago
As discussed in bug 888666, the time for mozContacts.getAll() to return 1000 contacts has regressed about 10%.

The current regression range window is:

  GOOD:  149175:8f805d3ef377      ~3650ms
  BAD:   149870:98a1e12a8686      ~3950ms
(Assignee)

Comment 1

5 years ago
Unfortunately it looks like we have multiple regressions.  Here are the results of my current bisecting:

    147614:615541ee101b - 3600ms
    149175:8f805d3ef377 - 3648ms, 3650ms, 3663ms
    149523:45415f31e536 - 3633ms, 3706ms, 3467ms, 3653ms
    149689:f5b6b5523719 - 3728ms, 3699ms, 3760ms
    149777:51b36c5fd45f - 3733ms, 3729ms, 3726ms
    149783:0c235f2f6afd - 3713ms, 3713ms, 3707ms
    149787:0f74e0b64257 - 3746ms, 3728ms, 3714ms
    149788:b7c5cd333e9c - 3719ms, 3731ms, 3739ms
    149789:a4f96de49668 - 3996ms, 3951ms, 3957ms
    149790:1065b60241f7 - 3959ms, 3947ms, 3944ms
    149800:346ce9e416cb - 3982ms, 3974ms, 3972ms
    149821:bfaa33785f73 - 3953ms, 3961ms, 3957ms
    149870:98a1e12a8686 - 3986ms, 3998ms, 3941ms
    150676:3a486112072b - 3900ms

This identifies a ~250ms regression at 149789:a4f96de49668 which is caused by bug 907077.

There also appears to be a separate regression of ~100ms between 149523:45415f31e536 and 149689:f5b6b5523719.

There may also be a smaller ~50ms regression prior to 149175:8f805d3ef377.

Since we have multiple issues I am going to track them as sub-bugs.
(Assignee)

Updated

5 years ago
Depends on: 927079
(Assignee)

Comment 2

5 years ago
Some more bisecting results:

- 147614:615541ee101b - 3600ms
- 149175:8f805d3ef377 - 3648ms, 3650ms, 3663ms
- 149523:45415f31e536 - 3633ms, 3706ms, 3467ms, 3653ms
- 149524:acdff324d588 - 3961ms, 3913ms, 3927ms
- 149535:2a0cea4c8eaa - 3931ms, 3954ms, 3956ms
- 149536:11d7e1b8531a - 3903ms, 3915ms, 3905ms
- 149545:22da748201eb - 3689ms, 3719ms, 3720ms
- 149565:f8787963a438 - 3750ms, 3763ms, 3739ms
- 149600:70fe2b31caf4 - 3719ms, 3733ms, 3724ms
- 149689:f5b6b5523719 - 3728ms, 3699ms, 3760ms
- 149777:51b36c5fd45f - 3733ms, 3729ms, 3726ms
- 149783:0c235f2f6afd - 3713ms, 3713ms, 3707ms
- 149787:0f74e0b64257 - 3746ms, 3728ms, 3714ms
- 149788:b7c5cd333e9c - 3719ms, 3731ms, 3739ms
- 149789:a4f96de49668 - 3996ms, 3951ms, 3957ms
- 149790:1065b60241f7 - 3959ms, 3947ms, 3944ms
- 149800:346ce9e416cb - 3982ms, 3974ms, 3972ms
- 149821:bfaa33785f73 - 3953ms, 3961ms, 3957ms
- 149870:98a1e12a8686 - 3986ms, 3998ms, 3941ms
- 150676:3a486112072b - 3900ms

Unfortunately it looks like that previous regression might be in the window 149523:45415f31e536 to 149545:22da748201eb.  An earlier version of bug 907077 landed in this same timeframe and may be masking the other regression commit.  It seems prior to that original 907077 commit times were about 50ms to 100ms faster than after it was backed out.

I think I'll have to manually backout 907077 during that timeframe and bisect again.
(Assignee)

Updated

5 years ago
Whiteboard: [c= p= s= u=] → [c= p=4 s= u=]

Updated

5 years ago
Component: DOM: Device Interfaces → DOM: Contacts
(Assignee)

Comment 3

5 years ago
I can confirm this is not in v1.2:

  mozilla-aurora 155912:4253a66382fa - 3572ms
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

5 years ago
I'm having trouble getting older versions of gecko to run with my gonk/gaia.  Since we found the most significant source of the regression already, I'm not sure the pay off is worth the cost of doing more bisecting here.  I'm going to go ahead and mark as fixed.
You need to log in before you can comment on or make changes to this bug.