Mozilla crashes after 'sox' failes to find cache file

VERIFIED DUPLICATE of bug 85542

Status

()

--
critical
VERIFIED DUPLICATE of bug 85542
18 years ago
16 years ago

People

(Reporter: jak, Assigned: serhunt)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When visiting http://www.upn.com, the plugger plugin is activating to play a
sound file, ultimately ends up calling the 'sox' program. The output from
Mozilla is as follows:

bash$ mozilla
sox: Can't open input file
'/home/jak/.mozilla/default/oyjej3cl.slt/NewCache/1BAF6D30d01': No such file or
directory
Gdk-ERROR **: X connection to :0.0 broken (explicit kill or server shutdown).
bash$

Updated

18 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 1

17 years ago
Also broken in Mozilla 0.9.3

Comment 2

17 years ago
We need a stacktrace or talkback id for this to be helpful.
Keywords: stackneeded

Comment 3

17 years ago
I can reproduce this with 2001-09-08-21 on Linux. I used the prebuilt binary of
plugger 3.3 which I downloaded from:
http://fredrik.hubbe.net/plugger/plugger-3.3-linux-x86-glibc.tar.gz

Talkback ID for this crash: TB35146671Z
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
I thikn we know this one already. plugger crash.

Incident ID 35146671
Stack Signature plugger.so + 0x3e3f (0x411fae3f) a20fd7ae
Bug ID
Trigger Time 2001-09-09 05:39:55
Email Address andre.dahlqvist@telia.com
User Comments This crash has been filed as bug #92739. It happens when you have
the plugger plugin installed and visits http://www.upn.com. The crash happens
immediately on load and it 100% reproducable.
Build ID 2001090821
Product ID MozillaTrunk
Platform ID LinuxIntel
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Stack Trace
plugger.so + 0x3e3f (0x411fae3f)
plugger.so + 0x464f (0x411fb64f)
ns4xPluginStreamListener::OnFileAvailable()
nsPluginStreamListenerPeer::OnFileAvailable()
nsPluginStreamListenerPeer::OnStopRequest()
nsHttpChannel::OnStopRequest()
nsOnStopRequestEvent::HandleEvent()
nsARequestObserverEvent::HandlePLEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xec40 (0x4034bc40)
libglib-1.2.so.0 + 0x10308 (0x4034d308)
libglib-1.2.so.0 + 0x10913 (0x4034d913)
libglib-1.2.so.0 + 0x10aac (0x4034daac)
libgtk-1.2.so.0 + 0x8d667 (0x4026e667)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1d64f (0x4048964f) 

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 85542 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.