Disabling telemetry through settings still shows "enabled" under about:telemetry

VERIFIED FIXED in Firefox 28

Status

defect
P1
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kjozwiak, Assigned: spohl)

Tracking

unspecified
Firefox 29
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox28 verified, firefox29 verified)

Details

(Whiteboard: [beta28] [defect] p=2 [qa-])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
When a user disables the "Telemetry" settings to OFF under "Windows Charm -> Settings -> Options", it will still appear as enabled under "about:telemetry" but disabled under "toolkit.telemetry.enabled" in "about:config". Switching the telemetry to "ON/OFF" should also enable & disable it under "about:telemetry". Seems like a major privacy issue as the user thinks it has been turned off but in reality it's still enabled.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Slide in the Windows Charm and select "Settings -> Options"
3) Under the "Options", switch the "Telemetry" feature to "OFF"
4) Go into about:config and take a look at toolkit.telemetry.enabled, will appear is disabled (correct behavior)
5) Go into about:telemetry and take a look at the top, it will show that it's still "enabled" in green (incorrect as it has been disabled by the user)

Current Behavior:

- Disabling the "Telemetry" under "Options" doesn't disable it under about:telemetry

Expected Behavior:

- Disabling the "Telemetry" option should trickle down to everything and disable it correctly throughout the browser
Blocks: metrobacklog
No longer blocks: metrov1backlog
Summary: Defect - Disabling telemetry through settings still shows "enabled" under about:telemetry → Disabling telemetry through settings still shows "enabled" under about:telemetry
Whiteboard: feature=defect c=data_submission u=metro_firefox_user p=0 → [defect] p=0
Seeking clarity.

When a user turns it off in the options menu, are you saying that's just cosmetic? And in fact it's still on? Or is the UI in about:telemetry not refreshing appropriately and it is, in fact, turned off?
(Reporter)

Comment 2

5 years ago
Karen,

Ya, it seems like turning "Telemetry" off under the "Options" is just cosmetic and DOESN'T disable it under about:telemetry

- Attached a screenshot to illustrate the problem

Quick recap:

- Change "Telemetry" to "OFF" under "Options"
- Go into about:config and "toolkit.telemetry.enabled" appears as "False"
- Go into "about:telemetry" and you'll notice it's still enabled (even though it's disabled under "Options" and "about:config")
Blocks: metrov1backlog
No longer blocks: metrobacklog
Could it be that about:telemetry was never updated for metro, and it is listening to the wrong pref? We'll need to check who's firing the observers, and who is subscribed.

Updated

5 years ago
Blocks: 956798
Whiteboard: [defect] p=0 → [beta28] [defect] p=0
Whiteboard: [beta28] [defect] p=0 → [beta28] [defect] p=2
(Assignee)

Updated

5 years ago
Assignee: nobody → spohl.mozilla.bugs
Blocks: metrov1it22
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
(Assignee)

Comment 4

5 years ago
I'm unable to reproduce this. It may have been fixed since it was originally reported. Kamil, could you confirm? Thanks!
Flags: needinfo?(kamiljoz)
(Reporter)

Comment 5

5 years ago
Juan/Stephen and myself went through this together and reproduced the problem on both Juan's Surface 2 and my Lenovo X1 Carbon.

Going to try reproducing the issue using the debug mode on the Carbon X1.
Flags: needinfo?(kamiljoz)
(Assignee)

Comment 6

5 years ago
Posted patch PatchSplinter Review
The telemetry pref is named differently in nightly/aurora, i.e. "toolkit.telemetry.enabledPreRelease" instead of "toolkit.telemetry.enabled". This patch tries to do what Android and other platforms are doing. A try build with this patch applied successfully fixed this bug:
https://tbpl.mozilla.org/?tree=Try&rev=e82a23661c01
Attachment #8357946 - Flags: review?(jmathies)

Updated

5 years ago
Attachment #8357946 - Flags: review?(jmathies) → review+
Priority: P2 → P1
https://hg.mozilla.org/mozilla-central/rev/9f1bede9516f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Verified as fixed on latest nightly (build ID: 20140119030202) using the STR from the description.
"Telemetry" is now shown turned off under about:telemetry.
Verified that turning Telemetry "ON" will also switch back in about:telemetry and about:config.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

5 years ago
Comment on attachment 8357946 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: about:telemetry will not reflect correctly whether telemetry is turned on or off.
Testing completed (on m-c, etc.): Verified on m-c (see comment 9).
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8357946 - Flags: approval-mozilla-aurora?
This metro-only patch does not need explicit approval for Aurora 28:
https://mail.mozilla.org/pipermail/metro/2014-January/000405.html
Keywords: checkin-needed
Whiteboard: [beta28] [defect] p=2 → [beta28] [defect] p=2 [approval-mozilla-aurora=metro-only]
Attachment #8357946 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/releases/mozilla-aurora/rev/748a06e03145
Keywords: checkin-needed
Whiteboard: [beta28] [defect] p=2 [approval-mozilla-aurora=metro-only] → [beta28] [defect] p=2
Whiteboard: [beta28] [defect] p=2 → [beta28] [defect] p=2 [qa-]
(Reporter)

Comment 13

5 years ago
Went through the following issue for verification during iteration #22 testing. Used the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-23-00-40-02-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-23-03-02-04-mozilla-central/

- Ensured that disabling telemetry data through the "Options" flyout disables the "toolkit.telemetry.enabledPreRelease" flag under about:config and disables it under about:telemetry
- Ensured that disabling the "toolkit.telemetry.enabledPreRelease" flag under about:config also disables telemetry under the "Options" flyout and about:telemetry
- Ensured that disabling telemetry data through about:telemetry also disables it under about:config and the "Options" flyout
- Ensured that the color coding under about:telemetry matches the correct state (Disabled/Red, Enabled/Green)
- Ensured that the button under about:telemetry is changing to the correct state (Disable Telemetry/Enable Telemetry)
- Went through all of the above test cases using different variations of snapped view

I also double checked and made sure that changing the telemetry pref under metro didn't change the pref under the desktop environment. Please let me know if that shouldn't be the case.
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.