context menu entry "View background image" doesn't appear

VERIFIED FIXED in Future

Status

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: grampp, Assigned: bugzilla)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2+)
Gecko/20010729
BuildID:    

context menu entry "View background image" doesn't appear although page contains
a background image


Reproducible: Always
Steps to Reproduce:
1.press rigth mouse button
2.
3.

Comment 1

17 years ago
Confirming on 2001072808 Win2k. Over to XP Toolkit/Widgets: Menus.
Assignee: asa → pinkerton
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets: Menus
Ever confirmed: true
QA Contact: doronr → jrgm
content
Assignee: pinkerton → blake
Component: XP Toolkit/Widgets: Menus → XP Apps: GUI Features
QA Contact: jrgm → sairuh
interesting, doesn't happen at other sites where a background image is used [eg,
my.yahoo.com, www.iconfactory.com]... but this is certainly a problem with
2001.08.06.0x bits on the three main platforms --when viewing this particular url.

i checked the source, and noticed that the filename for the image contains a
slash: background="Bilder/ziegel.gif" --unsure if that'd be the cause... cc'ing
some editor and parser folx to see if they might have ideas...
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

17 years ago
Very interesting! I don't know how the browser context menu decides if there's 
a background image exists, but the image path is certainly valid. The slash,
of course, simply means it's in a subdirectory relative to the page location.
The image loads just fine into a Composer doc when you use:
http://www.bnv-bamberg.de/home/ba5113/Baufinan/Bilder/ziegel.gif
as the SRC URL.

(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
(Assignee)

Comment 5

17 years ago
Created attachment 67605 [details] [diff] [review]
patch
(Assignee)

Comment 6

17 years ago
fix checked in.

bz notes that we also need to check for background specified in css for body and
html, but he cc'd me on another related bug to remind me to do that.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
vrfy fixed using 2002.02.13 comm bits on linux rh7.2, win2k and mac 10.1.2.

after seeing comment 6, please also see bug 50514 comment 37 for a test case for
a background specified via CSS.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.