Closed Bug 927586 Opened 6 years ago Closed 6 years ago

B2G desktop mochitests | application crashed [@ nsDOMWindowUtils::GetIsTestControllingRefreshes(bool*)]

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: ahal, Assigned: smaug)

References

Details

Attachments

(1 file)

E.g: https://tbpl.mozilla.org/php/getParsedLog.php?id=29203971&tree=Cedar#error2

This happens on a handful of tests, including:
content/base/test/test_bug326337.html
content/base/test/test_bug426646.html
content/base/test/test_bug557892.html
content/events/test/test_bug322588.html

There are likely more that I'll uncover as triaging progresses. Note that I can't reproduce this locally.
Bug 895345 possibly related?
Honza, does this crash look like it could be related to bug 895345? If so who can I bug to help me look into it?

Thanks!
Flags: needinfo?(honzab.moz)
Oh, yes, that method is totally missing a nullcheck.
Patch coming.
Attached patch patchSplinter Review
Based on how testing framework uses this method, returning false is probably
the safest option. Other option would be to throw.
Assignee: nobody → bugs
Attachment #818630 - Flags: review?(continuation)
Flags: needinfo?(honzab.moz)
Attachment #818630 - Flags: review?(continuation) → review+
https://hg.mozilla.org/mozilla-central/rev/999ed39dc0e7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
See Also: → 929090
Blocks: 931116
No longer blocks: 916127
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.