for-of iterator result should use object literal syntax instead of Object.create(null)

RESOLVED FIXED in mozilla27

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

Trunk
mozilla27
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c= p=1 s= u=])

Attachments

(1 attachment)

As discussed in bug 907077 comment 78 and comment 80 the es6 for-of iterator implementation should use object literal syntax instead of Object.create(null).  This is for two reasons:

 1) The spec says that the result should have %ObjectPrototype% as is its prototype.
 2) Its faster.

Patch to come.
Duplicate of this bug: 927619
Attachment #818137 - Flags: review?(jorendorff)
Attachment #818137 - Flags: review?(jorendorff) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
Whiteboard: [c= p= s= u=] → [c= p=1 s= u=]
https://hg.mozilla.org/mozilla-central/rev/9c8ab7e9ae41
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.