Closed Bug 927688 Opened 6 years ago Closed 6 years ago

Enable background thumbnailing on beta and release

Categories

(Toolkit :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: adw, Assigned: adw)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
We should enable background thumbnailing on the beta and release channels.  There are still many open bugs blocking bug 841495 and bug 870100, but crash bugs are the primary reason it's disabled.

Gavin and I discussed the remaining crashers blocking bug 899758, and the worst one is bug 898825 since it's the parent process that crashes.  Bug 893404 was also a parent-process crasher, but on closer look it doesn't actually seem to be a crash bug anymore, so I removed it from the list of crashers blocking bug 899758.

The other crasher blockers are content process crashes, which we gracefully recover from, failing assertions that don't actually crash the browser, or crashes that occur in OOP tabs and social but not in thumbnailing (so far, anyway, in some cases).  Bug 902755 is a hang, and I posted a patch there for review.

In summary, the one remaining, problematic blocker is bug 898825.  However, it's only speculated that it's related to thumbnailing, and crash-stats shows no reports in the last 28 days.  So I think it's safe to enable background thumbnailing on beta and release, but I would like to land the hang bug 902755 in the same cycle.

CC'ing Shane since Gavin said he might be interested since social also uses e10s.
Attachment #818176 - Flags: review?(mhammond)
Comment on attachment 818176 [details] [diff] [review]
patch

Review of attachment 818176 [details] [diff] [review]:
-----------------------------------------------------------------

woohoo :)  It might be worth getting a build peer to sign-off on the moz.build/Makefile.in change though.
Attachment #818176 - Flags: review?(mhammond) → review+
Comment on attachment 818176 [details] [diff] [review]
patch

gps, would you mind looking at this patch's changes to moz.build, Makefile.in, and browser.ini?  We're removing the RELEASE_BUILD checks everywhere to enable this feature and its tests on beta and release.
Attachment #818176 - Flags: review?(gps)
Attachment #818176 - Flags: review?(gps) → review+
Gavin and I decided not to block on the hang bug 902755, or on bug 914920, which I was able to reproduce recently.  We also decided not to uplift to Aurora/26.

https://hg.mozilla.org/integration/fx-team/rev/65d339e68163
https://hg.mozilla.org/mozilla-central/rev/65d339e68163
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Depends on: 911307
No longer depends on: 911307
Is this feature going to be enabled on Beta 27?
Flags: needinfo?(adw)
Yes.
Flags: needinfo?(adw)
You need to log in before you can comment on or make changes to this bug.