Closed Bug 92806 Opened 18 years ago Closed 18 years ago

need to support GB18030 in universal detector

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: shanjian, Assigned: shanjian)

References

Details

(Keywords: intl, topembed+, Whiteboard: [adt2], verified on trunk)

Attachments

(1 file, 2 obsolete files)

This is a bug duplicated from bugscape 7932. Since the same code also exist in 
mozilla tree, we need to fix in mozilla tree as well.

In our currect charset detector (universal), the state machine is still based 
on gb2312 encoding, that will lead to error for GB18030 specific code point. 
This need to be changed.
Attached patch proposed patch (obsolete) — Splinter Review
the proposed patch is "cvs diff" in ns tree. It is exactly the same as mozilla 
tree. This patch has been reviewed by ftang.
Switching qa contact to teruko for now. Teruko, feel free and re-assign further.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: intl
QA Contact: andreasb → teruko
blizzard, could you sr this one?
Status: NEW → ASSIGNED
Whiteboard: patch available, need sr
sr=blizzard
fix has been checked in. 
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Switching qa contact to ylong@netscape.com.
QA Contact: teruko → ylong
Since this checked-in has been a long time, I'm marking this one as verified here.

But seems the auto-detect with GB18030 pages are not working fine, I opened a
new bug 125628.

Status: RESOLVED → VERIFIED
The statemachine of universal charset detector should be updated. Reopen this bug. 
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attached patch new patch (obsolete) — Splinter Review
Attachment #43994 - Attachment is obsolete: true
explaination:

Basicly what I did is replacing the existing state machine with the new one
which already used is PSM charset detector. GB2312 is replaced by gb18030
because gb18030 is a superset. I didn't change the file name, because I don't
think it is really necessary to do so. 
Status: REOPENED → ASSIGNED
Whiteboard: patch available, need sr → patch available, need r/sr
frank/scc, could you r/sr?
Keywords: nsbeta1
Comment on attachment 78631 [details] [diff] [review]
new patch

r=ftang
please add comment about the part of the change are generated automatically by
the perl script
also, please add comment about the temp hack of using 2 bytes charlen to deal
with 4 bytes characters as a reminder for later.
Attachment #78631 - Flags: review+
nsbeta1+
[adt3], if we don't take the patch, most of the simplified chinese page will
still be detected as GB2312 and therefore show correctly. However, if the page
have 4 byte sequence, or GBK seqence, then we may detected them as other charset. 
Keywords: nsbeta1nsbeta1+
Whiteboard: patch available, need r/sr → [adt3]patch available, need r/sr
Attachment #78631 - Attachment is obsolete: true
Attachment #79857 - Flags: review+
Comment on attachment 79857 [details] [diff] [review]
patch with comment added

r=ftang, please ask for sr=
Comment on attachment 79857 [details] [diff] [review]
patch with comment added

r=ftang, please ask for sr=
change from [adt3] to [adt2] based on topembed+
Whiteboard: [adt3]patch available, need r/sr → [adt2]patch available, need r/sr
Whiteboard: [adt2]patch available, need r/sr → [adt2]patch available, need sr
Comment on attachment 79857 [details] [diff] [review]
patch with comment added

sr=scc
Attachment #79857 - Flags: superreview+
fix checked into trunk. 
Comment on attachment 79857 [details] [diff] [review]
patch with comment added

a=rjesup@wgate.com.  Please make sure it's in branch and trunk
Attachment #79857 - Flags: approval+
Verified auto-detect Universal works fine on 04-25 trunk build.
Whiteboard: [adt2]patch available, need sr → [adt2]
Blocks: 141008
since this one is fixed on trunk. mark this bug as fixed and ask qa to mark it
as verify on trunk 
Status: ASSIGNED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → FIXED
Add "verified on trunk" in status whiteboard.
Status: RESOLVED → VERIFIED
Whiteboard: [adt2] → [adt2], verified on trunk
This one probably needs a refresh approval from drivers, as the original
approval was provided on 04/24.
Blocks: 143047
Keywords: adt1.0.0
adding adt1.0.0+.  Please get drivers approval since the previous approval is
more than 3 days old and then checkin to the 1.0 branch.
Keywords: adt1.0.0adt1.0.0+
Keywords: approval
Adding adt1.0.1+ for adt approval for branch checkin for the 1.0.1 milestone. 
Please get drivers approval before checking in.
Keywords: adt1.0.0+adt1.0.1+
please checkin to the 1.0.1 branch ASAP. once there please remove the
mozilla1.0.1+ keyword and add the fixed1.0.1 keyword.
Keywords: mozilla1.0.1+
still waiting for driver approval.
Shanjian - Per IM with Jud, mozilla1.0.1+ = Driver's approval. Pls check this in
today. thanks!
patch checked into branch. 
Blocks: 146292
No longer blocks: 141008
Verified fixed on 06-05 branch build on WinXP-SC and linux RH7.2.
You need to log in before you can comment on or make changes to this bug.