If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When powering on a device for the first time with a SIM customization variant with app preloads, an app install success notification unexpectedly appears

VERIFIED FIXED

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jsmith, Assigned: Carmen Jimenez Cabezas)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Build: 10/17/2013 Master Leo

STR

1. Setup your build according to https://wiki.mozilla.org/B2G/QA/Customizations#Build_Setup with an AT&T US SIM

Expected

When the phone power on customization renders, no app install notification toast should appear.

Actual

When the phone power on customization renders, an app install notification toast appears for one of the apps preinstalled.
(Reporter)

Comment 1

4 years ago
Can UX comment here if this is a blocker for 1.2 or not? This kinda makes the first power on of the device seem off, as we're showing a toast that doesn't need to be there. This issue wasn't present in the 1.1 & 1.01 timeframes with apps customizations without variant customizations either. From an end user perspective, this would likely be perceived as a regression.
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: [systemsfe]
(Reporter)

Updated

4 years ago
Blocks: 893800
(Assignee)

Comment 2

4 years ago
I don't know if that's really a bug. 
From my point of view, the fact that the app installation message is shown is good, since it informs the user of the apps that are installed as part of/because of his operator choice. 

On 1.0.1. and 1.1 no apps were installed at boot time (they were all installed at build time), that's why there was no message. In any case, for a user to notice that he would have to have both a 1.0.1/1.1 device and a brand new device with 1.2 installed (since the FOTAs won't carry operator single variant apps). 

In any case, once UX says if this is a desirable behavior or not I can take this bug
(Reporter)

Comment 3

4 years ago
(In reply to Carmen Jimenez Cabezas from comment #2)
> I don't know if that's really a bug. 
> From my point of view, the fact that the app installation message is shown
> is good, since it informs the user of the apps that are installed as part
> of/because of his operator choice. 

I disagree with this. If you are first launching your phone for the first time, a user going to be really confused why this is showing up. If we were adding the apps after the fact (e.g. SIM inserted post FTE and restart of phone), then I still think a little bit odd to put in power on animation. What would likely make more sense would be display some explicit notification when the homescreen first displays.

Comment 4

4 years ago
I agree with Jason here. No banners (related to background app installation; others may apply) should appear while the user is going through the FTE.

The ideal scenario would be that the user finishes FTE and lands on the homescreen with whatever additional apps already there. There's no need for further information; this is the brand new phone as intended and perhaps even advertised (say, a partnership with a music service or something like that).

Comment 5

4 years ago
Removing ni? for UX since Rafa addressed this sufficiently, and because UX works with him closely.
Flags: needinfo?(firefoxos-ux-bugzilla)
(Assignee)

Updated

4 years ago
Assignee: nobody → cjc
(Assignee)

Comment 6

4 years ago
Created attachment 822820 [details] [review]
This fixes the described problem by not showing any installation notification during the FTU
Attachment #822820 - Flags: review?(ferjmoreno)

Comment 7

4 years ago
Comment on attachment 822820 [details] [review]
This fixes the described problem by not showing any installation notification during the FTU

Looks good to me, but you'll need Etienne's or Julien's r+ as I am not a peer of this code.
Attachment #822820 - Flags: review?(ferjmoreno)
Attachment #822820 - Flags: review?(etienne)
Attachment #822820 - Flags: feedback+
Comment on attachment 822820 [details] [review]
This fixes the described problem by not showing any installation notification during the FTU

Comments on github!
Please ping me if you need any help with sinon fake timers.

You can find inspiration here: https://github.com/mozilla-b2g/gaia/blob/master/apps/system/test/unit/update_manager_test.js
Attachment #822820 - Flags: review?(etienne)
(Assignee)

Comment 9

4 years ago
I updated the PR with the changes requested. Can you take another look at it?
Flags: needinfo?(etienne)
I'm really sorry I didn't catch this earlier, but the code involved is actually synchronous so we don't need the `TINY_TIMEOUT` nor the fake timers at all!

Otherwise this patch is good to go, so we just need to remove the fake timers.
Flags: needinfo?(etienne)
(Assignee)

Comment 11

4 years ago
I have changed what you requested. Can I ask for checkin with r=you, Etienne?
Flags: needinfo?(etienne)
Comment on attachment 822820 [details] [review]
This fixes the described problem by not showing any installation notification during the FTU

All good, congrats! :)
Attachment #822820 - Flags: review+
https://github.com/mozilla-b2g/gaia/pull/13116
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(etienne)
Resolution: --- → FIXED
https://github.com/mozilla-b2g/gaia/commit/72758c49ea3097b72a121578b193e54dc95e22cd
This is fixed, but isn't uplifted for 1.2. Is this a blocker for 1.2 finally, or is UX ok with 1.2 showing the toasts for the apps installation?
Flags: needinfo?(firefoxos-ux-bugzilla)
Asking for koi? per comment 4 and comment 5
blocking-b2g: --- → koi?
(Reporter)

Updated

4 years ago
blocking-b2g: koi? → koi+
status-b2g-v1.2: --- → affected
Uplifted 72758c49ea3097b72a121578b193e54dc95e22cd to:
v1.2: 6342dbd8eb0c9cdf613741de01b9b1c8cb19a48d
status-b2g-v1.2: affected → fixed
(Reporter)

Updated

4 years ago
Keywords: verifyme

Comment 18

4 years ago
No install success notification appears when following the provided steps.

1.2 Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131205004003
Gaia: 0659f16b9790b1cf9eba4d80743fcc774d2ffe3a
Gecko: af2c7ebb5967
RIL Version: 01.02.00.019.102 
Version: 26.0
Firmware Version: V1.2_20131115
Status: RESOLVED → VERIFIED
status-b2g-v1.2: fixed → verified

Comment 19

4 years ago
Removing Verifyme tag due to comment 18.
Keywords: verifyme

Updated

4 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)
You need to log in before you can comment on or make changes to this bug.