Unable to import some mozmill libraries (l10n) into the repository

RESOLVED WONTFIX

Status

Testing Graveyard
Mozmill
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: AndreeaMatei, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
I wanted to import l10n module [1] into a new library I'm creating for metro.
First I tried: 
> var l10n = {};
> Cu.import('resource://mozmill/modules/l10n.js', l10n);

but it failed with "export is not defined" at line 8:
https://github.com/mozilla/mozmill/blob/master/mozmill/mozmill/extension/resource/modules/l10n.js#L8

Then I tried with require:
> var l10n = require("l10n");

But it's failing with:
> "Module \"l10n\" not found"

So far I tested this on Windows 8, but it might unrelated to the platform.

We currently import frame.js (for example) successfully with the first method, but that module makes use of EXPORTED_SYMBOLS.
(Reporter)

Updated

4 years ago
Whiteboard: [mozmill-2.1?]
This module is not an old-style one but a securable module. So EXPORTED_SYMBOLS will not work.

As pointed out on IRC we set the module folder as rootPath, but somehow it doesn't look inside this folder?
https://github.com/mozilla/mozmill/blob/master/mozmill/mozmill/extension/resource/modules/frame.js#L507
This bug will not be taken for version 2.1. We might want to re-evaluate for 2.2.
OS: Windows 8 → All
Whiteboard: [mozmill-2.1?] → [mozmill-2.2?]
Mozmill will reach its end of life soon. We are currently working on getting all the tests for Firefox ported to Marionette. For status updates please see bug 1080766.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Whiteboard: [mozmill-2.2?]
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.