email_in.pl script fails with invalid token error

RESOLVED FIXED in Bugzilla 4.4

Status

()

Bugzilla
Incoming Email
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Phil Barrett, Assigned: glob)

Tracking

({regression})

4.4.1
Bugzilla 4.4
regression
Dependency tree / graph
Bug Flags:
blocking4.4.2 +

Details

(Whiteboard: [fixed by blocker])

Attachments

(1 obsolete attachment)

(Reporter)

Description

4 years ago
User Agent: Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.16

Steps to reproduce:

Upgraded to 4.4.1. Continued to use replies to bugzilla emails to comment on bugs.


Actual results:

No changes made to bugs. Examining the output of email_in.pl it looks like it fails on token checks:

<div class="throw_error">
<!--reason=invalid_token-->
    You submitted changes to email_in.pl with an invalid
    token, which may indicate that someone tried to abuse you, for instance
    by making you click on a URL which redirected you here <b>without your
    consent</b>.
  <p>
    Are you sure you want to commit these changes?
  </p>
</div>



Expected results:

Comment should have been added to bug

Comment 1

4 years ago
Created attachment 818948 [details] [diff] [review]
patch, v1
Assignee: incoming.email → LpSolit
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #818948 - Flags: review?(dkl)

Comment 2

4 years ago
Only affects 4.4.1 and trunk (regression due to bug 927736).
Depends on: 927736
Flags: blocking4.4.2+
Keywords: regression
Target Milestone: --- → Bugzilla 4.4
(Reporter)

Comment 3

4 years ago
That patch fixes it for me, thanks a lot.
Comment on attachment 818948 [details] [diff] [review]
patch, v1

Review of attachment 818948 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #818948 - Flags: review?(dkl) → review+

Updated

4 years ago
Flags: approval?
Flags: approval4.4?
(Assignee)

Updated

4 years ago
Flags: approval?
Flags: approval4.4?
Flags: approval4.4+
Flags: approval+

Comment 5

4 years ago
This bug is fixed by bug 930013. The patch here is no longer needed.
Assignee: LpSolit → glob
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Depends on: 930013
Flags: approval4.4+
Flags: approval+
Resolution: --- → FIXED
Whiteboard: [fixed by blocker]

Updated

4 years ago
Attachment #818948 - Attachment is obsolete: true

Updated

4 years ago
Duplicate of this bug: 930902
(Assignee)

Updated

4 years ago
Duplicate of this bug: 934381

Comment 8

4 years ago
Added to relnotes for 4.4.2
You need to log in before you can comment on or make changes to this bug.