[OS.File] xpcshell-test "test_unique.js" sometimes leaves files behind causing subsequent runs to fail.

RESOLVED DUPLICATE of bug 801376

Status

()

Toolkit
OS.File
--
minor
RESOLVED DUPLICATE of bug 801376
5 years ago
4 years ago

People

(Reporter: nmaier, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Async:ready][mentor=Yoric][lang=js])

(Reporter)

Description

5 years ago
Sometimes test_unique.js, introduced in bug 866571, leaves the dummy* files behind. Running the test again will then fail. You can fix that by removing the offending files yourself, of course.

I haven't really figured out any steps to reproduce yet, but it happened a couple of times so far, always on a slow Ubuntu VM... I *think* there test timeouts once or twice.

Would be great if the test made sure the directory was clean before running the code.
Assignee: nobody → marcos
Marcos, are you working on that bug?
Flags: needinfo?(marcos)
Assignee: marcos → nobody
Flags: needinfo?(marcos)
Whiteboard: [Async][mentor=Yoric][lang=js]
Whiteboard: [Async][mentor=Yoric][lang=js] → [Async:ready][mentor=Yoric][lang=js]
I couldn't reproduce it on OSX with 300+ times of test running.
Could we just collect all the paths and finally delete them to avoid that risk?
I suspect that this has been fixed in Bug 801376.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801376
You need to log in before you can comment on or make changes to this bug.