[v1.2] Write a test to import from VCF file on SD card on aurora

RESOLVED DUPLICATE of bug 934227

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 934227
4 years ago
4 years ago

People

(Reporter: Teodosia Pop, Assigned: AlinT)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gaia-ui-test])

(Reporter)

Description

4 years ago
Test the contacts app import from VCF file on the SD card:

This test case will require us to create a .vcf file and put it into the resources folder.

Setup:
1. Delete any existing VCF files
2. Push the VCF file from resources folder onto the sdcard

Test case
1. Start b2g
2. Load Contacts app
3. Settings menu
4. Tap import from Memory card
5. Go back to main Contacts list
6. Assert that the contact is listed and the name is correct.

This was done for the master branch in bug 927348 and the changes are similar.
(Reporter)

Updated

4 years ago
Whiteboard: [gaia-ui-test]
(Assignee)

Updated

4 years ago
Assignee: nobody → alin.trif
(Assignee)

Updated

4 years ago
Depends on: 928635
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 934227
You need to log in before you can comment on or make changes to this bug.