Closed Bug 928439 Opened 7 years ago Closed 7 years ago

Helper app icon appears in wrong tab when a page loads in a background tab

Categories

(Firefox for Android :: General, defect)

26 Branch
All
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox25 --- unaffected
firefox26 - verified
firefox27 --- verified

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Steps to reproduce:
1) Open any page with a direct link to an image file, e.g. https://people.mozilla.org/~mbrubeck/
2) Long-click on a link to an image file (e.g. "needs.png" on the page above) and choose "Open in new tab"

Expected results: The image opens in a background tab.  The helper app icon appears only after you switch to that tab.

Actual results: The image opens in a background tab, but the helper app icon appears in the foreground tab.

Side note: To avoid bugs like this (and simplify life for add-on authors), it would be nice if the PageActions API allowed a pageaction to be associated with a tab, so the browser could handle hiding/showing them automatically based on the selected tab.  I'll file a separate bug for that.
Attachment #819078 - Flags: review?(wjohnston)
Comment on attachment 819078 [details] [diff] [review]
patch

Review of attachment 819078 [details] [diff] [review]:
-----------------------------------------------------------------

Hmm.. I think I thought pageshow wouldn't fire for background tabs.
Attachment #819078 - Flags: review?(wjohnston) → review+
Depends on: 928443
https://hg.mozilla.org/mozilla-central/rev/e0c1a2edfbd8
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 819078 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 899376 (new "Helper App" feature)

User impact if declined: "Helper App" icon appears in wrong tab in certain cases

Testing completed (on m-c, etc.): Landed on m-c on October 19.

Risk to taking this patch (and alternatives if risky): Very low risk one-line Android-only patch that only touches the new Helper App feature.

String or IDL/UUID changes made by this patch: None.
Attachment #819078 - Flags: approval-mozilla-aurora?
Comment on attachment 819078 [details] [diff] [review]
patch

no need to track, we can take this low risk uplift.
Attachment #819078 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tested with Galaxy Nexus (4.3) using:
Firefox 26 Beta 8 

Steps to reproduce:
1) Open any page with a direct link to an image file, e.g. https://people.mozilla.org/~mbrubeck/
2) Long-click on a link to an image file (e.g. "needs.png" on the page above) and choose "Open in new tab"

The Helper app icon doesn't appear on the foreground page - only in the background. 
Marking this verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.