Closed Bug 928491 Opened 7 years ago Closed 3 years ago

add logs in marionette server side describing what actions are being taken

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: mdas, Unassigned)

Details

We found that when things go awry in a marionette test in tbpl, we don't often know what caused this problem. You'll see the last command sent by the client, but you won't know what the server did with this command and what actions it was taking before an error occurred. This doesn't give us any real information on why things are failing, and results in us having to dive deeper to figure out the root cause.


We want to increase the server side logging (enable the increased logging via a pref), so we can more easily trace what's happening when we hit a failure.
A lot of code has been rewritten with a lot of logging and we're much better now. closing
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
We still would need more logging for some commands, but I agree that we are in a way better shape those days. So lets get the rest filed as separate bugs once needed.
You need to log in before you can comment on or make changes to this bug.