Closed Bug 928758 Opened 8 years ago Closed 8 years ago

Page flickering on Win8.1 when scrolling page

Categories

(Core :: Graphics, defect)

27 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 928727

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [bugday-20131021])

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/0d316980f21f
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131020030202


Steps To Reproduce
1. Disable HWA (may be required)
2. Open about:home
3. Reduce window height so that vertical scroll bar appears
4. Scroll the page with mouse wheel / dragging thumb

Actual Results:
Page flickering

Expected Results:
No flickering

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/9b1deed063e4
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131019032250
Bad:
http://hg.mozilla.org/mozilla-central/rev/3af0c2e6012c
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131019184353
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9b1deed063e4&tochange=3af0c2e6012c


Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5861a2de43d3
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131018124112
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a46ff1a56160
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131018124705
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5861a2de43d3&tochange=a46ff1a56160

Regressed by:
fc7cc3c1dccf	Benoit Girard — Bug 928123 - Avoid PushGroup during simple FillRect. r=Bas
Following pages also flicker.
"Get Add-ons" page in about:addons
about:config
Graphics
--------

Adapter Description: VMware SVGA 3D
Adapter Drivers: vm3dum64 vm3dum vm3dgl64 vm3dgl
Adapter RAM: 128
Device ID: 0x0405
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (6.3.9600.16384)
Driver Date: 7-12-2013
Driver Version: 7.14.1.5025
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic Blocked for your graphics card because of unresolved driver issues.
Vendor ID: 0x15ad
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
windowLayerManagerRemote: false
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
disabling gfx.content.azure.enabled solves the problem
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928727
Whiteboard: [bugday-20131021]
You need to log in before you can comment on or make changes to this bug.