Log network requests even if the network monitor isn't the currently active tab

RESOLVED DUPLICATE of bug 862341

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED DUPLICATE of bug 862341
4 years ago
4 years ago

People

(Reporter: Samuel Hodge, Unassigned)

Tracking

24 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

1. Go to any website
2. Open the developer tools and switch to a tab other than the network monitor
3. Refresh the page
4. Switch to the network monitor tab


Actual results:

The network monitor is empty.


Expected results:

The network monitor should have logged all requests made since the page refresh. 

It becomes a hassle when you are in the debugger and realize a bug is caused by a faulty net response and then find the log empty because the network monitor tab wasn't activated. Having the developer tools open should be reason enough to log all network requests.
(Reporter)

Updated

4 years ago
Component: Untriaged → Developer Tools: Netmonitor
(Reporter)

Updated

4 years ago
OS: Windows NT → Windows 8.1
(Reporter)

Updated

4 years ago
Version: 24 Branch → unspecified
(Reporter)

Updated

4 years ago
Version: unspecified → 24 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862341
You need to log in before you can comment on or make changes to this bug.