Closed Bug 928976 Opened 6 years ago Closed 6 years ago

[Marketplace] Marketplace won't launch

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

Details

(Keywords: regression, smoketest)

Attachments

(3 files)

Buri, while running:

Gaia   e10553a9099545157636a057c170c77fb4cb93a5
SourceStamp 7823e2985daf
BuildID 20131021040204
Version 27.0a1

STR:
1. Launch marketplace on two different devices, same build.
2. App won't launch and appears to crash, although no crash report is generated.

Logcat Attached.
I have some crash reports queued up on this phone, one of them is:

https://crash-stats.mozilla.com/report/index/6d06a112-cf27-49b0-beaa-bbc5b2131021
That looks like a Gonk crash. Once we have a regression window, I'll hunt for the regressing Gonk patch and get it backed out.
blocking-b2g: --- → 1.3?
Keywords: smoketest
QA Contact: nkot
Regression window:

-last working-
BuildID: 20131018040217
Gaia: 18c2ab4b7b2d4cacee90fb85e97354142b2fad4a
Gecko: 855da6d8a327
Version: 27.0a1

-first broken-
BuildID: 20131019040204
Gaia: d0861c2913a57cb681ec4cd4d52d73cc0f479ac9
Gecko: e25e62d174ed
Version: 27.0a1
Dave mentioned in IRC he was going to look into this. Putting needinfo on him to see what he finds out during his investigation of this smoketest blocker.
Flags: needinfo?(dhylands)
I also have this issue :(
I tried to reproduce on my unagi, and when I launch MarketPlace I get one of two crashes (both occur in the Browser app):

10:18:17.016 462/462                     Gecko  I   [Child 462] WARNING: NS_ENSURE_TRUE(mDocShell) failed: file /home/work/B2G-unagi/birch/embedding/browser/webBrowser/nsWebBrowser.cpp, line 366
10:18:17.016 462/462                     Gecko  I   [Child 462] WARNING: NS_ENSURE_TRUE(domWindow) failed: file /home/work/B2G-unagi/birch/embedding/browser/webBrowser/nsDocShellTreeOwner.cpp, line 86
10:18:17.097 462/462                MOZ_Assert  F   Assertion failure: tabChild, at ../../../dist/include/mozilla/net/NeckoCommon.h:130
10:18:17.097 462/462                      libc  F   Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)

or

10:22:28.781 590/590                     Gecko  I   [Child 590] WARNING: NS_ENSURE_TRUE(inBrowser) failed: file /home/work/B2G-unagi/birch/embedding/browser/webBrowser/nsDocShellTreeOwner.cpp, line 82
10:22:28.791 590/590                MOZ_Assert  F   Assertion failure: mHandleCreatedByOtherProcessWasUsed, at /home/work/B2G-unagi/birch/ipc/glue/FileDescriptor.cpp:69
10:22:28.791 590/590                      libc  F   Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)

I'll attach the backtraces. I'm going to try and reproduce on my Buri to see if I get the same or different crashes. The fact that I get different crashes suggests a race of some type.
Flags: needinfo?(dhylands)
> 
> 10:22:28.781 590/590                     Gecko  I   [Child 590] WARNING:
> NS_ENSURE_TRUE(inBrowser) failed: file
> /home/work/B2G-unagi/birch/embedding/browser/webBrowser/nsDocShellTreeOwner.
> cpp, line 82
> 10:22:28.791 590/590                MOZ_Assert  F   Assertion failure:
> mHandleCreatedByOtherProcessWasUsed, at
> /home/work/B2G-unagi/birch/ipc/glue/FileDescriptor.cpp:69

This is a shutdown assertion and tracked in bug 918595.
According to Marcia - this is working now with the backout Dave did apparently gets marketplace to startup reliably. Smoketest today will confirm this as well. Works for me.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.