Closed Bug 928977 Opened 6 years ago Closed 6 years ago

In some cases, the clip set on the page doesn't update when the addressbar hides

Categories

(Firefox for Android :: Toolbar, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox25 --- unaffected
firefox26 --- fixed
firefox27 --- verified

People

(Reporter: kats, Assigned: kats)

References

Details

On the latest nightly on a Nexus 4:

STR:
1. Load http://chrislord.net/files/mozilla/fixed7.html
2. Zoom in a bunch
3. Scroll down the page so that address bar scrolls out of view

Expected:
The visible area is entirely green with a thin grey border

Actual:
The bottom of the screen (about the height of the address bar) is clipped. Switching out of Fennec and back into Fennec fixes it, so it's just a temporary issue. Forcing a reflow doesn't appear to fix it though.

I believe this to be a regression from bug 916125 but I don't want to back out 916125 since it's a pretty minor regression and 916125 is needed for more important things. I think the problem here is just that the clip needs to be updated as the address bar hides.
Is this the same as bug 915492?
Doesn't sound the same, no. This one is only on 27 right now.
Duplicate of this bug: 930775
I'm guessing bug 928441 probably fixed this.
And yes, it looks like bug 928441 fixes this. Marking fixed by dependency. (Also updating status flags since this bug does affect 26 because 916125 was uplifted there).
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 928441
Resolution: --- → FIXED
Assignee: nobody → bugmail.mozilla
Target Milestone: --- → Firefox 27
Status: RESOLVED → VERIFIED
It it my understanding that this is a recent regression, only users of nightly and aurora would have ever seen it. So this doesn't seem like something that should be put in release notes. Or am I missing something?
Yeah that's my understanding too. Erin, was there a reason you requested relnote on this bug?
Flags: needinfo?(elancaster)
I'm pretty sure I rel-note requested it thinking it would be good to call out as a known issue for aurora but it looks like it isn't needed.
Flags: needinfo?(elancaster)
You need to log in before you can comment on or make changes to this bug.