Last Comment Bug 929065 - OOM crash in jit-tests/tests/gc/bug-914614.js with --ion-parallel-compile=on --ion-eager
: OOM crash in jit-tests/tests/gc/bug-914614.js with --ion-parallel-compile=on ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine: JIT (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla27
Assigned To: Terrence Cole [:terrence]
: general
: Hannes Verschore [:h4writer]
Mentors:
: 928914 (view as bug list)
Depends on:
Blocks: 912928 929221
  Show dependency treegraph
 
Reported: 2013-10-21 11:32 PDT by Terrence Cole [:terrence]
Modified: 2013-10-22 15:33 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
oom_crash-v0.diff (1.81 KB, patch)
2013-10-21 11:32 PDT, Terrence Cole [:terrence]
bhackett1024: review+
Details | Diff | Splinter Review

Description User image Terrence Cole [:terrence] 2013-10-21 11:32:17 PDT
Created attachment 819870 [details] [diff] [review]
oom_crash-v0.diff

Currently crashing on tip. Configured with: CC="gcc" CXX="g++" CCACHE_CPP2="1" CCACHE_UNIFY="1" ./configure --enable-optimize --enable-debug --enable-signmar --enable-stdcxx-compat --enable-ctypes --enable-trace-malloc --with-ccache=/usr/bin/ccache --disable-shared-js --with-system-nspr --without-intl-api

Ran with: ./jit-test/jit_test.py ./ctx/js --tbpl --args="--ion-parallel-compile=on"

The attached patch fixes the crash in normal runs. Valgrind, however, still insists there are several invalid write and then triggers AssertThreadCanAccessRuntime several hundred times before crashing somehow. I'm not sure what's going on here: presumably a race. Brian, could you take a look at this?
Comment 1 User image Terrence Cole [:terrence] 2013-10-21 13:54:48 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0bd2b4b3f715
Comment 2 User image Hannes Verschore [:h4writer] 2013-10-21 16:24:55 PDT
*** Bug 928914 has been marked as a duplicate of this bug. ***
Comment 3 User image Wes Kocher (:KWierso) 2013-10-22 15:33:45 PDT
https://hg.mozilla.org/mozilla-central/rev/0bd2b4b3f715

Note You need to log in before you can comment on or make changes to this bug.