Closed Bug 929088 Opened 6 years ago Closed 6 years ago

Typing "about:home" into URL bar hides awesomescreen if "about:home" is the selected tab

Categories

(Firefox for Android :: Awesomescreen, defect)

27 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 935604
Tracking Status
firefox25 --- unaffected
firefox26 --- affected
firefox27 --- affected

People

(Reporter: mcomella, Unassigned)

References

Details

Attachments

(1 file)

1) Open a new tab (or go to about:home)
2) Click the URL bar
3) Type in "about:home" (it's already there but type it in anyway - I imagine having the search provider come up is necessary)
4) Hit enter to go

Expected: The awesomescreen reappears after the search provider screen disappears
Actual: The awesomescreen does not reappear. Note:
  * Switching to other about:home tabs does not make the awesomescreen reappear, but selected web content will appear. The awesomescreen will reappear if a tab on "about:home" is selected after selecting web content
  * Selecting the URL bar when the awesomescreen is hidden will not show the awesomescreen, however, typing to bring up the search provider and deleting the text you just typed (hiding the search provider) will display the awesomescreen.
I'm able to reproduce this issue on the latest versions of Nightly and Aurora, and also on Beta 26.0b1.
I can't reproduce on Beta 25.0b8
Attached image FF 28 Nightly
Using the provided steps, on LG Nexus 4 (Android 4.2.2) with Firefox for Android 28.0a1 (2013-10-31) please see the attachment
Very similar to bug 935604 which has more investigation and tracking flags set up. Might be a dupe, setting a dependency to keep track of this case.
Depends on: 935604
Patch #2 in bug 935604 fixes this issue.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935604
You need to log in before you can comment on or make changes to this bug.