Closed Bug 929125 Opened 7 years ago Closed 7 years ago

Set shared library path in jit-test harness

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27

People

(Reporter: dminor, Assigned: dminor)

References

Details

Attachments

(1 file)

On some of the test platforms the directory containing the js interpreter libraries is not in the shared library path, preventing the interpreter from running.

Setting the library path appropriately in the env will fix linux32 opt and debug. The same symptom (every test fails) shows up on the Windows XP and Windows 7 opt builds, but may be caused by something else.
Blocks: 928500
This fixes the linux32 builds on a releng loaner test machine.

Try run here: https://tbpl.mozilla.org/?tree=Try&rev=7c7ce7ee52db
Assignee: nobody → dminor
Status: NEW → ASSIGNED
Attachment #820354 - Flags: review?(terrence)
Comment on attachment 820354 [details] [diff] [review]
Set shared library path

Review of attachment 820354 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense. r=me
Attachment #820354 - Flags: review?(terrence) → review+
https://hg.mozilla.org/mozilla-central/rev/24db71586336
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Blocks: 858621
You need to log in before you can comment on or make changes to this bug.