Closed Bug 929161 Opened 6 years ago Closed 6 years ago

Switching to iframe by name in Marionette hangs and closes socket

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 929175

People

(Reporter: james.h.evans.jr, Assigned: automatedtester)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Consider a page containing an <iframe> element like this:

<iframe src="formPage.html" marginheight="0" marginwidth="0"
        topmargin="0" leftmargin="0" allowtransparency="true"
        frameborder="0" height="600" scrolling="no" width="120"
        id="iframe1" name="iframe1-name" />

Issue a Marionette switchToFrame command like the following:

{"to":"0","name":"switchToFrame","sessionId":"13","parameters":{"id":"iframe1-name","focus":true}}



Actual results:

Marionette appears to hang, and the communication socket is closed.


Expected results:

For the frame to be successfully switched to.
Assignee: nobody → dburns
Blocks: webdriver
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicating this with bug 929175 since refactoring that appears to have fixed that issue
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929175
You need to log in before you can comment on or make changes to this bug.