Change the webpay landing flow to be triggered from JS

RESOLVED DUPLICATE of bug 987824

Status

P2
normal
RESOLVED DUPLICATE of bug 987824
5 years ago
4 years ago

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

5 years ago
Currently the landing page in webpay is triggered by a GET request to the lobby. That starts the transaction async via celery and returns the lobby page to the user. The lobby page then does the processing for the login and the pin.

Before the transaction is created though we want to pass through the region and carrier info. This information will determine how the transaction will be processed by the backend, so the sooner we have the information the better.

So when we land on the webpay home page we shouldn't process the JWT. Instead we should just return all the HTML for the home page and then fire the JWT off to the webpay server... that POST off to the server will contain the JWT and also the MCC and MNC info that we've got from the client.
(Reporter)

Updated

5 years ago
Blocks: 926575
(Reporter)

Updated

5 years ago
Depends on: 837289
Priority: -- → P2
(Reporter)

Updated

5 years ago
Blocks: 942361
(Reporter)

Comment 1

4 years ago
This is being done for Boku in bug 987824.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987824
You need to log in before you can comment on or make changes to this bug.