Closed Bug 929563 Opened 8 years ago Closed 3 years ago

Add-on-provided overflowable toolbars won't have an overflow listener if added before registerArea call

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Gijs, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: addon-compat, Whiteboard: [Australis:P4-])

This is fallout from the patch for bug 909779. It's not hard to fix, but we'd already held that bug up long enough, so I really wanted to push this to a followup - so here we are! :-)
Whiteboard: [Australis:P5] → [Australis:P3]
I'm going to call this P4 since I'm a little dubious about the value of it to 3rd party toolbars (eg, even our own add-ons toolbar never bothered to deal with overflow). But if it's actually causing a Real Problem for addons then we should raise it back up.
Whiteboard: [Australis:P3] → [Australis:P4]
Whiteboard: [Australis:P4] → [Australis:P4-]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 980155
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Add-on-provided overflowable toolbars won't have an overflow listener → Add-on-provided overflowable toolbars won't have an overflow listener if added before registerArea call
Add-ons can no longer provide toolbars, never mind overflowable ones.
Status: REOPENED → RESOLVED
Closed: 7 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.