'Authentication error' message flashes for a second on clicking the 'View transactions' link

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Assigned: davidbgk)

Tracking

Points:
---

Details

(Whiteboard: kanbanzilla[Review], URL)

(Reporter)

Description

4 years ago
steps to reproduce:
1. Log in as the owner of a paid app
2. Navigate to 'Compatibility & Payments' page for that app
3. Click on 'Add, manage or view transactions for your payment account'
4. In the lightbox, click on 'View transactions'
5. Click again on the same link

expected behavior:
Since the bango portal takes a while to load, let's disable the link so that users don't click it multiple times

observed behavior:
Clicking twice on the link (while waiting for the page to load) results in 'Authentication error' message being flashed to the user.

screencast: http://screencast.com/t/wQefXeh8v3q5
Component: Developer Pages → Payments/Refunds
Assignee: nobody → david

Updated

4 years ago
Version: 1.0 → 1.4
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Whiteboard: kanbanzilla[Review]
(Assignee)

Comment 2

4 years ago
https://github.com/mozilla/zamboni/commit/2c964807a123df313513df9913bd7f0f1f7d3f34
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.