Closed Bug 929817 Opened 8 years ago Closed 7 years ago

[B2G] [1.2] [l10n] [Contacts]: Current location header from Facebook contacts is shown in English on every language

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S2 (28feb)

People

(Reporter: ckreinbring, Assigned: jmcf)

Details

(Keywords: l12y, Whiteboard: LocRun1.2)

Attachments

(3 files)

Description:
The text of the header for a Facebook contact's current location is shown in English regardless of the device's set language.

Repro Steps:
1) Update Buri to Build ID: 20131022004000
2) Set the device language to any language except English.
3) Restart the device.
4) Launch the Contacts app.
5) Tap the Settings gear icon then tap the Sync Friends switch.
6) When the Facebook login screen loads, enter a valid username and password then tap Log In.
7) Once the contacts list loads, select a contact with a current location in its profile then tap Update.
8) Return to the contact list and open the Facebook contact's details.
9) Observe the appearance of the header for the contact's current location.

Actual:
The text is shown in English.

Expected:
The entire text is shown in the chosen language.

Environmental Variables
Device: Buri 1.2 Commercial RIL
Build ID: 20131022004000
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/7453a764f9a9
Gaia: 00d5964eabf95a6a8a632420dfa36fc76dcbc9b7
Platform Version: 26.0a2
RIL Version: 01.02.00.019.082

Notes:
Repro frequency: 100%
See attached screenshot
Assignee: nobody → mri
Attached file patch v1.0
Attachment #821040 - Flags: review?(jmcf)
Comment on attachment 821040 [details]
patch v1.0

incomplete solution
Attachment #821040 - Flags: review?(jmcf) → review-
Summary: [B2G] [l10n] [l10n] [Contacts]: Current location header from Facebook contacts is shown in English on every language → [B2G] [1.2] [l10n] [Contacts]: Current location header from Facebook contacts is shown in English on every language
Assignee: mri → nobody
It would seem that the core of the problem is that we do not have an address type 'current' which facebook does. Therefore I think a quick pragmatic and low risk solution would be to add a 'current' type to the list of address types. 

ni? me if that does not work for you jose, or you consider an improved alternative solution
Assignee: nobody → jmcf
Attached file 16450.html
fixed as per the UX recommendations
Attachment #8378286 - Flags: review?(francisco.jordano)
Comment on attachment 8378286 [details]
16450.html

Thanks,

merge once travis is green and the tree is open!
Attachment #8378286 - Flags: review?(francisco.jordano) → review+
Hi Fabrice,

This is a pretty low risk patch concerning a localization issue. Can we land this in master in order to have it for v1.4?

thanks!
Flags: needinfo?(fabrice)
Yes, you can land - just have good test coverage, and don't break anything.
Flags: needinfo?(fabrice)
landed in master:

It is only a localization issue. no tests needed

https://github.com/mozilla-b2g/gaia/commit/e6f80a4770f576c8b517ff85e33fea0e8e914750
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S2 (28feb)
You need to log in before you can comment on or make changes to this bug.