Closed Bug 929886 Opened 6 years ago Closed 6 years ago

[B2G] Leo graphic broken while playing game

Categories

(Core :: Graphics, defect)

26 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 917444

People

(Reporter: pyang, Unassigned)

Details

Attachments

(1 file)

Attached video leo_gaming.3gp
STR:
 - Install "where's my water" as packaged app.
 - Launch the app
 - Click start to enter the first stage

ACTUAL:
 - The upper part of screen keeps twinkling as attached video shown.

EXPECT:
 - The visual element can be rendered smooothly
Summary: [B2G] Leo sparkling while playing game → [B2G] Leo graphic broken while playing game
That's black flickering - there's been a few gfx bugs related to this in the 1.2 timeframe. Might be a dupe of one of those bugs.
Blocks: GFXB2G1.2
blocking-b2g: --- → koi?
Component: General → Graphics
Product: Boot2Gecko → Core
Version: unspecified → 26 Branch
For the koi? nom btw - this is blocking getting a target 1.2 partner application working on FxOS correctly.
Whiteboard: [games:p?]
It might be related to Bug 917444, if the game uses 2d canvas.
(In reply to Sotaro Ikeda [:sotaro] from comment #3)
> It might be related to Bug 917444, if the game uses 2d canvas.

or WebGL
How can I get "where's my water" app?
(In reply to Sotaro Ikeda [:sotaro] from comment #5)
> How can I get "where's my water" app?

Emailing you about this right now.
I received the app from paul yang. It seems the dup of Bug 917444. There are two way to solve the problem.
- [1] Ensure frame complete by reading one pixcel (Bug 917444)
- [2] ANativeWindow backed EGLSurface (Bug 767484)

For the short term(v1.2), we are going to fix the problem by [1]. For long term, [2] is going to be implementad.

By applying [1], I confirmed that the problem was fixed.
No longer blocks: GFXB2G1.2
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [games:p?]
Duplicate of bug: 917444
You need to log in before you can comment on or make changes to this bug.