Closed Bug 929968 Opened 6 years ago Closed 6 years ago

[Keyboard] adding BÉPO french layout

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Nildeala, Assigned: Nildeala)

References

Details

Attachments

(1 file, 2 obsolete files)

The BÉPO keyboard layout is the Dvorak equivalent for the French language. It is used by a great amount of french-speaking people and should be implemented. (As it is built in most GNU/Linux distributions.)

See more information about the layout here : http://bepo.fr
Hi, please do the following:

1. Click add an attachment
2 [review]. Put the pull request link there
3. Set reviewer flag to '?' and assign to janjongboom@gmail.com (thats me, I'm also under suggested reviewers)
4. Submit

Now it's in the review queue and someone will take a look.
Assignee: nobody → schoewilliam
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #821157 - Flags: review?(janjongboom)
This bug is gonna merge-conflict badly with bug 884752.
Yep, I'm waiting for Norwegian keyboard support to land as well for that bug.
Depends on: 884752
So, how is this going ?
Waiting for bug 884752 to have landed.
Comment on attachment 821157 [details] [review]
adding  the french BÉPO layout to the built-in keyboard.

I'm gonna land this before the other bug. So reviewing

1. Please revert the change in apps/settings/js/keyboard.js. If this is a real issue, please create another bug.
2. We need all commits squashed, please see this guide to combine your commits: https://gist.github.com/janjongboom/7194742
3. The build should pass the TravisCI tests. If you follow the guide and rebase against master that should be ok.
4. Done and build is green? Please change review flag from - to ? again (and assign to me).

Thanks for your work! I've tested it and it works fine (please |make clean| beforehand).
Attachment #821157 - Flags: review?(janjongboom) → review-
Attachment #821157 - Flags: review- → review?(janjongboom)
All is okay :)
Same pull request as before, but on the v1.2 branch.
Attachment #824177 - Flags: review?(janjongboom)
Comment on attachment 824177 [details] [review]
adding the french BÉPO layout to the built-in keyboard (V1.2 BRANCH)

This adds the french BÉPO (french equivalent to en-Dvorak) layout to the built-in gaia keyboard.
Attachment #824177 - Flags: approval-gaia-v1.2?
Comment on attachment 824177 [details] [review]
adding the french BÉPO layout to the built-in keyboard (V1.2 BRANCH)

This patch has not been nominated for uplifting to 1.2. 1.2 features have long been closed, so I'm r-'ing this :-)
Attachment #824177 - Flags: review?(janjongboom)
Attachment #824177 - Flags: review-
Attachment #824177 - Flags: approval-gaia-v1.2?
Comment on attachment 821157 [details] [review]
adding  the french BÉPO layout to the built-in keyboard.

Hi, almost there. The bottom bar (contains ?123, space bar, etc.) is not consistent with other keyboard layouts (e.g. French) even though the content is the same. Can you adjust the width of the keys in the bottom bar to be the same as normal French layout? Other than that I'm happy, thanks!

Please re-r? me when done.
Attachment #821157 - Flags: review?(janjongboom)
(In reply to Jan Jongboom [:janjongboom] from comment #13)
> Comment on attachment 821157 [details] [review]
> adding  the french BÉPO layout to the built-in keyboard.
> 
> Hi, almost there. The bottom bar (contains ?123, space bar, etc.) is not
> consistent with other keyboard layouts (e.g. French) even though the content
> is the same. Can you adjust the width of the keys in the bottom bar to be
> the same as normal French layout? Other than that I'm happy, thanks!
> 
> Please re-r? me when done.

Hi, thanks !
I used the same width as on a layout that has the exact same number of keys (the Norsk layout), is that still a problem anyway ? I'll try to adjust though.
(In reply to Jan Jongboom [:janjongboom] from comment #13)
> Comment on attachment 821157 [details] [review]
> adding  the french BÉPO layout to the built-in keyboard.
> 
> Hi, almost there. The bottom bar (contains ?123, space bar, etc.) is not
> consistent with other keyboard layouts (e.g. French) even though the content
> is the same. Can you adjust the width of the keys in the bottom bar to be
> the same as normal French layout? Other than that I'm happy, thanks!
> 
> Please re-r? me when done.

Moreover, I don't think I can since BÉPO needs the layout to have a width set to 11 (so does the Norsk layout). That alters the keys of the bottom bar. Unless I modify the ratio of the "?123" key (which is not possible it seems), I can't change that.
If that's a real issue. What I can do is setting back the layout to be 10 wide, so that I could keep the bottom bar consistent with the other French layout (that would honestly be a shame, but not a big deal if necessary).
Flags: needinfo?(janjongboom)
Lemme think of a nice solution...
Flags: needinfo?(janjongboom)
(In reply to Jan Jongboom [:janjongboom] from comment #17)
> Lemme think of a nice solution...

All right. Let me know asap !
I've discussed with other bépo defenders (#bepo on freenode irc) and it seems like setting back the width to 10 keys isn't a great deal. Allow me to do it and update my pull request :).

We'll be both happy !
Flags: needinfo?(janjongboom)
Attachment #824177 - Flags: review-
Attachment #821157 - Flags: review?(janjongboom)
Hey William, can you rebase against master? Your commit can't be merged at the moment.
Flags: needinfo?(janjongboom)
(In reply to Jan Jongboom [:janjongboom] from comment #20)
> Hey William, can you rebase against master? Your commit can't be merged at
> the moment.

done
I did ****.
I got all lost in the rebase thing...
I’m worried by the low benefit/risk ratio here: I think there could be way more people confused by enabling a BÉPO layout by mistake than BÉPO users of FirefoxOS.

(In reply to William Dorffer [:schoewilliam] from comment #0)
> The BÉPO keyboard layout is the Dvorak equivalent for the French language.

Nit: it’s *a* Dvorak equivalent, not *the* Dvorak equivalent. I agree it’s by far the most popular ergonomic layout for French, but it hasn’t been around for decades like US Dvorak.

> It is used by a great amount of french-speaking people

It’s used by a lot of French-speaking FLOSS enthusiasts (I’ve used it as well and contributed to this project), but I don’t think it’s fair to say it’s used by a “great amount” of French-speaking people.

Naive questions:
 • do we even support the US Dvorak layout in Gaia yet?
 • is it possible to submit custom keyboard layouts on the Marketplace?
:kaze, yes, there is Dvorak. It is not possible to add keyboard layouts in marketplace, just full keyboard apps. I don't mind landing alternative keyboard layouts.
Flags: needinfo?(kaze)
If that’s the only way to add a keyboard layout, I agree it makes sense.

For my information, how do I enable US-Dvorak on the current Gaia? Dvorak isn’t listed in the “Add more keyboards” panels on my device.
Flags: needinfo?(kaze)
You'll have to include it in the build (keyboard layouts are in an ENV variable now). See gaia/keyboard/layouts/en-Dvorak.js
Attachment #824177 - Attachment is obsolete: true
Attachment #821157 - Attachment is obsolete: true
Attachment #821157 - Flags: review?(janjongboom)
Mmh, the Travis CI build failed. Any idea why ?
Flags: needinfo?(janjongboom)
Comment on attachment 830102 [details] [review]
adding the french BÉPO layout to the built-in keyboard.

Probably unrelated. r=me. Landed in https://github.com/mozilla-b2g/gaia/commit/ed5b8ba7245f363094851978512b9fc1ddb4db13.

Thanks for contributing (and for your patience :-)).
Attachment #830102 - Flags: review?(janjongboom) → review+
Awesome ! Thank you :)
Flags: needinfo?(janjongboom)
I have one more question, should we add an entry for the layout in this file https://github.com/mozilla-b2g/gaia/blob/master/shared/resources/keyboard_layouts.json ?
Flags: needinfo?
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?
Resolution: --- → INVALID
Resolution: INVALID → FIXED
I have this version of Firefox os on my flame: https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-flame/
and i don't have BÉPO french layout.
Flags: needinfo?(schoewilliam)
Hi,
That's normal, you need to add it to your gaia build. See this https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/make_options_reference#Enabling_IME_layout_and_dictionaries
Flags: needinfo?(schoewilliam)
You need to log in before you can comment on or make changes to this bug.