Nightly updates should be able to install without user prompt

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: brion, Unassigned)

Tracking

27 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Every time Nightly downloads an update, the user has to click through the notification and the system .apk installer dialog.

As someone who dogfoods the Nightly builds for Android, it would be nice to not have to do this every morning -- the automatic updates on desktop are much appreciated.

In theory it's possible to do background installation of update apks, as Google Play is now able to do app updates without prompting.

I'm not sure how difficult this would actually be to achieve -- especially since the app is replacing itself -- but figured there should be a bug entry in here in case somebody wants to poke at it.
(Reporter)

Updated

5 years ago
Severity: normal → enhancement
OS: Mac OS X → Android
Hardware: x86 → ARM
The Google Play app is web content mostly. If you mean the auto update of apps without permission changes this only works for apps listed on the Google Play store. Updating apps installed outside of Play go through the app update dialog. There are not any simple ways around this.
(Reporter)

Comment 2

5 years ago
Oh well, worth checking!

Resolved UNFEASIBLE :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.