WRMB: A few urls (mostly x.compuserve.com) don't load in mozilla & mfcEmbed

VERIFIED WORKSFORME

Status

()

Core
Embedding: APIs
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: David Epstein, Assigned: Chak Nanga)

Tracking

({topembed})

Trunk
x86
Windows NT
topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
1. Launch mozilla.exe build or mfcEmbed. I used the 7/27 build.
2. Enter one of these urls:
http://mediasolutions.compuserve.com/
http://newsroom.compuserve.com
http://forums.adult.compuserve.com/scripts/flisapi.dll/cvww39.jpg?ViewFile&SRV=PhotoModel&FID=10011
http://www.compuserve.com/atplay/blockbreaker.asp
I also tried my acct at Waterhouse. www.waterhouse.com. I entered my acct &
psswd on the home page login.
3. Press Enter.
Result: Url doesn't load. mfcEmbed flashes "sending request" msg in status area,
then a quick "connecting" msg (also in mozilla) but then stop light appears. I
checked against 6.1. All urls bring up a "you have request a secure/insecure"
dlog, and they load fine.
(Reporter)

Comment 1

17 years ago
per WRMB 7972, marking keyword topembed.
Keywords: topembed
(Reporter)

Comment 2

17 years ago
Put WRMB in the summary. From WRMB 7972.
Summary: A few urls (mostly x.compuserve.com) don't load in mozilla & mfcEmbed → WRMB: A few urls (mostly x.compuserve.com) don't load in mozilla & mfcEmbed

Comment 3

17 years ago
All these URLs work for me, running mfcEmbed from the full and embedding builds.
Can you retest?
(Reporter)

Comment 4

17 years ago
This is still happening for me in full mozilla build (0.9.3+ 20010807), mfcEmbed
and testEmbed. In the mozilla console window, I get "Error loading URL xxx" for
each of these urls (incl trying to enter name/psswd for waterhouse acct).
(Assignee)

Comment 5

17 years ago
->Chak
Assignee: adamlock → chak
(Assignee)

Comment 6

17 years ago
Trying all these URLs in MfcEmbed from yesterdays build render the pages just fine.

All these URLs redirect to some form of a login page which render as expected.

Marking WORKSFORME.

Also in the future if there are page rendering issues they should be assigned to
the tracking bug which the Komodo war room people are maintaining since these
are not embedding bugs per se.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Ran mfcembed 8/6 from the bin directory. None of the URL worked for me.

Comment 8

17 years ago
ran all the url's in mozilla. the mozilla build i have is  8/7. No url are 
loading. It says the page is done loading but show's only blank page. The same 
url's work fine in Netscape 4.7.
(Assignee)

Comment 9

17 years ago
This is strange. It works for me and for Adam.

Let's take a look tomorrow when i'm at NSCP......Thanks
(Reporter)

Comment 10

17 years ago
Thanks Dharma and Ashish for checking this out. OK, I think I see what's
happening. In 6.1, all of these URLs bring up "you have requested a secure doc"
prompt, then redirect to https. psm probably needs to be installed; no https I
tried is working in mozilla. I'll reopen until this is all clarified. Thanks
Chak for taking a look tomorrow.
(Reporter)

Comment 11

17 years ago
reopen
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 12

17 years ago
Hi David : 

I think, the reason these are not working for you is because you do not have the
PSM dlls.

Here's what you could do to verify this:

1. If you're not building PSM you should build it. I think all you need to do is
to set "BUILD_PSM2" env var to "1", pull and rebuild the Mozilla and test these URLs

2. If you do not want to build PSM, please get the embedding nightly builds and
test with that. These builds include PSM support.

3. You could also ask Tracy Walker to verify this with the nightly builds he has.

Thanks
(Reporter)

Comment 13

17 years ago
I couldn't get mozilla to build using the psm switch. I've been getting fatal
errors in gmake.exe . MfcEmbed is running, but the urls aren't working. I did
see "xxx could not be found" for the first 2 urls I tried, but then it reverted
to the old behavior (nothing happens when loaded).

(Assignee)

Comment 14

17 years ago
Hi David,

If you're having problems building with PSM you can verify this with the nightly
embedding builds which include PSM components

If you still want to build PSM the buid directions are at :
http://www.mozilla.org/projects/security/pki/psm/buildpsm.html

Please make sure:
1. You have the BUILD_PSM2 env var set to 1
2. Do an "nmake -f client.mak pull_and_build_all"
[If that does not work you may want to do an "nmake -f client.mak clobber_all"
and then do a "nmake -f client.mak pull_all" and then an "nmake -f client.mak
build_all"]

In any of cases above please make sure that the PSM clode is being pulled/built
by observing the dos window where you're doing the build

Chak
(Reporter)

Comment 15

17 years ago
In the debug builds, the urls aren't redirecting because psm isn't installed.
These urls are working fine in the 8/17 nightly build (which has psm). marking
this bug worksforme. If I find urls not loading in the nightly builds, I'll
enter another bug for that.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

17 years ago
.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.