Closed Bug 930160 Opened 6 years ago Closed 6 years ago

crash in java.lang.NullPointerException: at org.mozilla.gecko.home.TopSitesPage$1.onItemClick(TopSitesPage.java)

Categories

(Firefox for Android :: Awesomescreen, defect, critical)

27 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox26 --- affected
firefox27 --- affected

People

(Reporter: aaronmt, Assigned: lucasr)

References

Details

(Keywords: crash)

Crash Data

Attachments

(2 files)

This bug was filed from the Socorro interface and is 
report bp-80fee604-f17c-49b4-b5a8-731f92131022.
=============================================================

java.lang.NullPointerException
	at org.mozilla.gecko.home.TopSitesPage$1.onItemClick(TopSitesPage.java:174)
	at org.mozilla.gecko.home.HomeListView$1.onItemClick(HomeListView.java:112)
	at android.widget.AdapterView.performItemClick(AdapterView.java:297)
Attached patch PatchSplinter Review
Not sure what could cause the grid adapter to be null.
Prevention is better than cure.
Attachment #821904 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 821904 [details] [diff] [review]
Patch

Is it OK to continue in the function? Or should we just return? Just asking.
The function should continue. We're just averting a crash (when the gridAdapter is null -- which means, no grid is shown -- which is weird).
Comment on attachment 821904 [details] [diff] [review]
Patch

Review of attachment 821904 [details] [diff] [review]:
-----------------------------------------------------------------

Same here, I'd prefer to wait for steps to reproduce before landing something like this. This can be a symptom of a broader bug in our UI that we don't want to hide. Unless this is a top crasher?
Attachment #821904 - Flags: review?(lucasr.at.mozilla) → review-
Ok, possible STR:
Open nightly.
Have about:home opened to Top Sites
Tap one of the links (not the top site screengrabs) quickly and repeatedly (over 5 times) and you will crash
Sriram, could you have a look at this again and see if you can find the root cause of this bug? Tyler has provided STR in comment #5.
Flags: needinfo?(sriram)
Assignee: nobody → sriram
Keywords: steps-wanted
26 is affected here according to the summary in comment #0, although the number of crashes is quite small.
Status: NEW → ASSIGNED
Assignee: sriram.mozilla → nobody
Assignee: nobody → lucasr.at.mozilla
Duplicate of this bug: 961881
Comment on attachment 8364334 [details] [diff] [review]
Discard item clicks on top sites after the fragment gets destroyed (r=mfinkle)

Managed to reproduce this locally using the STR from comment #5. It seems there's a short window of time where pending item click events might get handled after the fragment gets destroyed.
Attachment #8364334 - Flags: review?(mark.finkle)
Attachment #8364334 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/0e7f583a8f1a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Flags: needinfo?(sriram.mozilla)
Depends on: 965822
You need to log in before you can comment on or make changes to this bug.