Closed Bug 930372 Opened 6 years ago Closed 6 years ago

Disable DirectShow MP3 support in Firefox 26 on Vista+, use WMF for MP3 decoding

Categories

(Core :: Audio/Video, defect)

x86_64
Windows Vista
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla27
Tracking Status
firefox26 --- verified

People

(Reporter: cpearce, Assigned: cpearce)

Details

Attachments

(1 file)

We landed some changes to MP3FrameParser recently that caused durations to be incorrectly calculated for some MP3s. We're using this in the DirectShow MP3 <audio> backend, which is enabled on all Windows version on Aurora (Fx26). Previously we used Windows Media Foundation for MP3 playback on Windows Vista an up, so if we ship using the MP3 playback on Vista using the DirectShow MP3 backend we'll ship a regression; we'll report the MP3 durations incorrectly for some MP3 that we otherwise wouldn't with the WMF MP3 backend.

So I propose that we disable DirectShow MP3 decoding on Vista and up, and rely on the WMF backend to decode MP3 until we can fix the duration calculation. We'll still report bad MP3 durations on Win XP, but we won't be shipping a regression, since we never actually supported MP3 on WinXP before.
Attached patch PatchSplinter Review
Assignee: nobody → cpearce
Attachment #821462 - Flags: review?(paul)
Attachment #821462 - Flags: review?(paul) → review+
Landed on m-c for Firefox 27.
We will need this in Firefox 26 as well.
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d86150342ca
Comment on attachment 821462 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 861693 (in Firefox 26), enables MP3 playback in <audio> on Windows XP using DirectShow, and switches playback of MP3s on Windows Vista and later to use DirectShow instead of Windows Media Foundation.

User impact if declined: On Windows Vista and later Firefox will start to incorrectly report the durations of some MP3 files when played in <audio> elements. Before bug 861693 landed we used Windows Media Foundation to play MP3s (on Vista and later only), and that accurately estimated the duration of MP3s.

This patch reverts us to use Windows Media Foundation to play MP3s on Vista and later, so that we won't regress the duration calculation on Vista and later. We'll still incorrectly estimate the duration of MP3s in some cases on Windows XP, but we didn't play MP3 before bug 861693 on Windows XP, so it's not technically a regression there, and at least we'll still be adding MP3 support on XP in Fx26.

Testing completed (on m-c, etc.): This patch reverts us to use a code path (on Windows Vista and later) that we had previously shipped without issue since Firefox 21.

Risk to taking this patch (and alternatives if risky): Very low.

String or IDL/UUID changes made by this patch: None.

I just landed this patch on m-c for Firefox 27, but we need this in Firefox 26. If aurora approved is not granted in time for the Firefox 26 to Beta uplift, please grant this beta approval instead of aurora approval, so that we can get this into Firefox 26. Thanks!
Attachment #821462 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/0d86150342ca
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Attachment #821462 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Are there any known websites QA can use to verify this is fixed or to check for potential regressions?
Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Using firefox 26 beta 2 (build ID: 20131104182142) I can confirm that WMF is used for MP3 decoding on Windows 7 x64 and Windows 8 x64.

On windows Vista I could not play mp3 files (drag & drop to browser or file -> open), the "Open with / Save file" dialog is displayed. 

On about:config the options were set to true as it follows:
  media.windows-media-foundation.enabled=TRUE
  media.windows-media-foundation.play-stand-alone=TRUE
  media.windows-media-foundation.use-dxva=TRUE
  media.directshow.enabled=TRUE
Cornel, based on your testing I think we can mark this verified, although there may be a follow-up bug.

Chris, what do you think about comment 7?
Status: RESOLVED → VERIFIED
Keywords: verifyme
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #8)
> Cornel, based on your testing I think we can mark this verified, although
> there may be a follow-up bug.
> 
> Chris, what do you think about comment 7?

MP3 plays for me on Vista. I can't replicate Cornel's (Firefox on Vista failing to play MP3) results. 

I tested the following builds in a Vista Business VM in VMWare Workstation:

Beta: Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0
Aurora: Mozilla/5.0 (Windows NT 6.0; rv:27.0) Gecko/20100101 Firefox/27.0
Nightly: Mozilla/5.0 (Windows NT 6.0; rv:28.0) Gecko/20100101 Firefox/28.0

MP3 playback of http://pearce.org.nz/video/zurie.mp3 works for me in these builds in Vista Business.
You need to log in before you can comment on or make changes to this bug.